News

2016 Cali T - backup display stopped working

Discussion in 'California/Portofino/Roma' started by MrBobT, Feb 20, 2021.

  1. MrBobT

    MrBobT Rookie

    Dec 7, 2020
    33
    Full Name:
    robert s towery
    Hi everyone. Today I took the wife out driving for the first time. When I went to back up into the garage, having pressed the R button, the car went into reverse, but the screen went blank. There was also a steady beeping, about 1.5 seconds apart. Not the rapid one like if you don't have your seat belt on (super annoying BTW).

    I tried putting it in first, back to R. Then I turned the car off, waited a few seconds, hit the R button, again the screen went blank (it had been displaying the radio info). I drove in 1st gear forward, stopped the car, R again, same result.

    It has worked just fine until today.

    Any ideas (besides trip to the dealer)?
     
  2. To remove this ad click here.

  3. Snewton94024

    Snewton94024 Formula Junior

    Apr 24, 2015
    419
    Silicon Valley
    Full Name:
    Steve Newton
    try opening and closing the drivers door as you sit in it after you start it and shut it off; then, restart it.
     
  4. thomastrain

    thomastrain Rookie

    Oct 30, 2019
    21
    Full Name:
    Steve CI
    One thing you can try is to disconnect the battery. Follow the procedure in your owners manual to disconnect the battery, wait 15 minutes and reconnect the battery following the procedure. This will reset your systems and may correct the issue. The Cali T head unit is quirky in my experience.


    Sent from my iPhone using FerrariChat
     
    whatheheck likes this.
  5. MrBobT

    MrBobT Rookie

    Dec 7, 2020
    33
    Full Name:
    robert s towery
    I'm beginning to think my Cali T has a Windows 3.1 OS???????
     
  6. SLViper1

    SLViper1 Formula Junior
    Silver Subscribed Owner

    Mar 25, 2014
    586
    Nashville/Destin
    Full Name:
    Steve
  7. To remove this ad click here.

  8. jordanfsl

    jordanfsl Karting

    Dec 11, 2010
    80
    Los Angeles
    Mine went to a blue screen. I went through a LOT to get it working again, and learned more than I ever wanted to about Ferrari parts. For example, the backup cameras are different if your car has/does not have front cameras or CarPlay. As to why, no one knows.

    I have some spare parts for this as well. The rear pieces necessary to fix this can only be obtained from a dealer directly, it’s flagged as a collision part (rear deck lid strip) or whatever and the typical sources cannot get them.
     
    whatheheck likes this.
  9. jordanfsl

    jordanfsl Karting

    Dec 11, 2010
    80
    Los Angeles
    Also, the beeping is normal when the car is in reverse.
     
  10. MrBobT

    MrBobT Rookie

    Dec 7, 2020
    33
    Full Name:
    robert s towery
    I don't recall hearing this before. I have some hearing issues and repeated beeping just doesn't go over well with me.
     
  11. XSpeed

    XSpeed Formula Junior

    Jan 6, 2019
    348
    Full Name:
    SX
    happened to me because of the battery. run the engine 15 mins idle at open air. then switch off and on and try again.
     
  12. To remove this ad click here.

  13. MrBobT

    MrBobT Rookie

    Dec 7, 2020
    33
    Full Name:
    robert s towery
    I ended up not doing anything. The next time I drove the car it just worked. Drove it again yesterday and backed up many times, worked each time. Glitch!
     
    smtrx likes this.
  14. stevecomp

    stevecomp Formula Junior

    Mar 1, 2013
    738
    South Australia
    Full Name:
    Steve
    If it’s in the sun it can go a bit funny, I’ve had that happen to me.
     
  15. 355GD

    355GD Rookie

    Apr 10, 2015
    3
    Newcastle upon Tyne
    Full Name:
    Graham Dark
    I too had the media screen go blank but I also developed a System Not Programmed warning on the TFT. I disconnected the battery and went through the procedure in the owners manual for a restart and everything was back. Seems this will happen with even a minor voltage fluctuation from the battery, and especially if not on the tether and not used for 5-7 days.
     
  16. lucasines

    lucasines Karting

    Apr 22, 2016
    72
    Paris
    Full Name:
    Gilles
    If I you start Carplay before to start to drive, you can get a black screen with your front or rear camera.
     
  17. thomastrain

    thomastrain Rookie

    Oct 30, 2019
    21
    Full Name:
    Steve CI
    This happened to me repeatedly on my 2017 Cali T. There is a firmware update for the head unit that the dealer installed and thus resolved the problem. I can now have the phone plugged in before I drive with no issues. If you still have the extended warranty ask the dealer to get clearance from Ferrari to upload the new firmware.


    Sent from my iPhone using FerrariChat
     
  18. lucasines

    lucasines Karting

    Apr 22, 2016
    72
    Paris
    Full Name:
    Gilles
    Thank you very much for your +++ contribution.
    My car C
     
  19. lucasines

    lucasines Karting

    Apr 22, 2016
    72
    Paris
    Full Name:
    Gilles
    Sorry for my short cut answer :)
    My car 17 Cali T HS is still covered with 5 years extended warranty.(3+2)
    I have informed my dealer to check if there is any update to correct this 2 months ago to apply for the next service.
    Thanks again for your contribution
    Regards
     

Share This Page