News

2018 488 stuck in “WET” mode

Discussion in 'Technical Q&A' started by Yun chang, Nov 28, 2019.

  1. Yun chang

    Yun chang Rookie

    May 20, 2019
    3
    So when the car heats up after 10 min, all the messages pop up on dash and it says “go to dealer” and gets stuck in wet mode. It still drives and shifts normally but it feels like a civic when u step on it which kills the whole experience lol. If I turn it off and let it sit for a minute then turn it back on, it goes back to normal temporarily but then the warnings come back. I replaced the battery with no resolve. It only has 1700 miles on it and I drive it at least 5 times a week. I’m super bummed about this issue and dropped it off at the dealer today hoping they’ll fix it for good. Has anyone else dealt with this issue?
    Image Unavailable, Please Login
     
  2. To remove this ad click here.

  3. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    Funny how it says.. go to dealer. It should say, go to someone who knows what they are doing. It needs to have the codes pulled and diagnosed. On the face of it, possibly the accelerator pedal has an internal fault.
     
  4. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    What was the outcome from the dealership? All fixed?
     
  5. Yun chang

    Yun chang Rookie

    May 20, 2019
    3
    Still there, I’ll lyk once they fix it hoping it won’t take another week‍♂️
     
  6. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    Thanks for keeping us posted. It might benefit others once we know the outcome. Cheers.
     
  7. To remove this ad click here.

  8. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    Looks like we will never know!
     
  9. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    Or even care to respond lol!
     
  10. mdrums

    mdrums Formula Junior

    Jun 11, 2006
    870
    Tampa
    Full Name:
    Mike
    Poof and he’s gone!....
     
    Andy 355 likes this.
  11. Andy 355

    Andy 355 Formula Junior

    Jun 2, 2013
    414
    Sydney
    Mdrums... i was beginning to think i was the omega man ha ha ha!!
     
    mdrums likes this.
  12. To remove this ad click here.

  13. Luisr69

    Luisr69 Rookie

    Dec 20, 2020
    4
    Sunny Isles Florida USA
    Full Name:
    Luis R Jimenez
    My 488 just last week had a similar issue however no check engine light and no warning to go to the dealer just stuck on wet mode in all types of warning lights it all happen after my battery went dead and I had to jumpstart the car drove the car home order a new battery replaced it myself and lights are still on car drives normally however suspension damping in traction control on not working.

    Just a month ago I lost church again someone unplug my battery tender and had a similar issue however was not stuck on wet mode in receiver to reset it after restarting the car

    Let me know if someone has encountered a section please since my next stop will have to be my local Ferrari dealership


    Sent from my iPhone using FerrariChat.com mobile app
     

Share This Page