Buy

328 Stalk Help

Discussion in 'Technical Q&A' started by Kyle Veit, Sep 24, 2021.

  1. Kyle Veit

    Kyle Veit Rookie

    Dec 24, 2019
    5
    Full Name:
    Kyle Veit
    Hello.
    My 86 328 brake lights and turn signal lights do not seem to work and I believe it has something to do with the stalk. The green little lights on the dash don't even turn on at all when the blinkers are on. I replaced the stalk a year ago because I was encountering a problem of only the right side brake lights working and the headlights only turning on in an odd position on the headlight switch. After I replaced the stalk with a much better condition one, the brake lights and headlights seemed to work fine. A few months later, I am encountering the same problems except, neither of the brake lights works and the headlights again only turning on in a very odd position, and turn signals not working at all. Also, my hazard switch is stuck up I believe the spring is messed up so the hazards do not turn off unless you jam a hammer to keep it down. How do I go about removing the hazard switch and reinstalling a different one?

    I need help with this I was told I should clean the stalk connections and I did that with a battery terminal cleaner I got at Napa and still, nothing works.
     
  2. To remove this ad click here.

  3. Steve Magnusson

    Steve Magnusson Two Time F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    21,401
    Texas
    Full Name:
    Steve Magnusson
    What version 328? US, euro, Swiss? The brake lights and turn signals not working from the same fault would probably put the failure way upstream (can't think, without checking, how the anything in the headlight stalk or turn signal stalk would affect the brake lights operation, but need to know version to look at the correct corresponding wiring diagram).
     
  4. Kyle Veit

    Kyle Veit Rookie

    Dec 24, 2019
    5
    Full Name:
    Kyle Veit
    I believe it is a US spec.
     
  5. Steve Magnusson

    Steve Magnusson Two Time F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    21,401
    Texas
    Full Name:
    Steve Magnusson
  6. Kyle Veit

    Kyle Veit Rookie

    Dec 24, 2019
    5
    Full Name:
    Kyle Veit
  7. To remove this ad click here.

  8. raemin

    raemin Formula 3

    Jan 16, 2007
    1,051
    Lyon (FR)
    Full Name:
    R. Emin
    I presume you can disconnect the stalk and bypass the spade connectors in order to mimic the stalk, if it still does not work your problem is not on the stalk itself. My own 400i had plenty of light faults, that were related to an ugly modification presumably made by the dealer when importing the car from Italy.

    If its the stalk, unobtainium supply can fix it ( http://www.unobtainiumsupply.com/ ) .
     
  9. Steve Magnusson

    Steve Magnusson Two Time F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    21,401
    Texas
    Full Name:
    Steve Magnusson
    The brake lights and emergency flasher (which then supplies +12V to the turn signal system) get +12V power from the same place. Recommend you:

    1. Check fuse #23 (15A) -- if blown (and continues to blow) this may be due to your failed emergency flasher switch (so that would need to be fixed first)

    2. If fuse #23 is OK, try unplugging, inspecting the two green wire connection, and replugging the w connector to wipe the connections. Bottom line is those two green wires in the w connector need to be +12V when the key is "on" for the brake lights and turn signals to work (but the emergency flasher switch also has to be OK in the "off" position to then send +12V to the turn signal system).

    Image Unavailable, Please Login
     

Share This Page