News

355 power loss

Discussion in 'Technical Q&A' started by tim355, Aug 20, 2004.

  1. tim355

    tim355 Karting

    Nov 7, 2003
    57
    I own a 1995 355 Spider. I was driving home from Seattle last night and when I went around a corner the engine suddenly lost power. After turning the car off and on a few times (still no help) I limped the car home 20 miles or so but struggled at every hill and stop sign. This morning I drove the car to town ( no issues) but in town when I started it up again I had the same problem. It's like I've lost all power on 1 bank. I have not had a "slow down" or "check engine" light come on. Any ideas what I should check for?
     
  2. To remove this ad click here.

  3. BigHead

    BigHead Formula Junior

    Oct 31, 2003
    992
    Outside of Boston
    Full Name:
    Dennis
    Bad ECU, very common. Try swapping from side to side, see if the other side is afflicted. But it should light up your "Slow down" light. Hmmm....

    vty,

    --Dennis
     
  4. Rjones355

    Rjones355 Karting

    Jul 6, 2004
    62
    Rancho Murieta, CA
    Full Name:
    Ryan Jones
    I had a similar problem, I unpluged the fuel pump fuses and the air flow meters, and the problem went away. It has not came back as of yet, I am also confused because like you no lights came on. If you figure it out let me know.

    Ryan
     
  5. f355spider

    f355spider F1 World Champ
    Rossa Subscribed Owner

    May 29, 2001
    17,061
    USA
    Full Name:
    Hugh G. Rection
    Interesting that it is "intermittent", is it possible that the connectors to the ECU's need a thorough cleaning...and possibly treated with some contact enhancer like Stabilant 22? Or is intermittent operation, just the sign of a failing one?
     
  6. tim355

    tim355 Karting

    Nov 7, 2003
    57
    thanks guys, I'll follow your suggestions, hope it's not an ECU. Anyone Know what they cost?
     
  7. To remove this ad click here.

  8. tim355

    tim355 Karting

    Nov 7, 2003
    57
    Well after a lot of work I finally traced the problem down to a broken connector in the fuse box under the passengers foot rest. (relay female pin for 1-4 injectors) This seems really wierd. Car only has 26K miles on it. Has anyone else needed to replace the fuse box? Anyone out there have a part-out 1995 355 with a fuse box I can buy?? I'm sure a new one from Ferrari is very expensive.
     
  9. jeffdavison

    jeffdavison F1 Rookie
    Silver Subscribed

    Jul 29, 2002
    2,500
    Suwanee Georgia
    Full Name:
    Jeffrey Davison
    I had a power loss from a couple of fouled spark plugs. Put a new set in and vviola! vroom vroom. About a $50 buck fix.

    JD
     
  10. FL 355

    FL 355 Formula 3

    Nov 3, 2002
    1,665
    Ft Laud
    Full Name:
    Frank Lipinski
    Tim

    FerrariAds.com on this site. Add 2239
     
  11. fatbillybob

    fatbillybob F1 World Champ
    Consultant Owner

    Aug 10, 2002
    19,023
    socal
    Geez Tim,

    I hate electronics. Can you explain to me the process you use to trace down such a problem and what are you using to do it. I need some lessons from a wizard with a VOM!
     
  12. To remove this ad click here.

Share This Page