News

355 Rough starting and idling?

Discussion in 'Technical Q&A' started by DrewH, Jan 8, 2004.

  1. DrewH

    DrewH F1 Rookie
    Silver Subscribed

    Nov 4, 2003
    4,596
    Vancouver, BC Canada
    Full Name:
    Andrew
    I took my 99 355 Spider for it's last spin in late November and after winding the car out the check engine light came on?

    The next day when I went to start it it didn't want to start and I could only keep it running by keeping my foot on the gas. At first I thought it may be a battery/alternator problem as it was in the stereo shop the week before and I thought they might have drained the battery so I bought and installed a new battery.

    The car still has the same problem with the new battery. If there was a problem with the alternator the car should run good until the new battery is drained.

    After the car runs for 5 minutes or so it seems to idle fine without holding my foot on the gas?

    I can't get it to the dealer as there is snow/salt everywhere and I got it stuck on my driveway trying to take a picture of it.

    DrewH
     
  2. To remove this ad click here.

  3. pino

    pino Karting

    Nov 1, 2003
    208
    South Central PA
    The first thing you will need to do is find out why the check engine light is on.
    This is done by either an SD1 (Ferrari's super computer)
    or with an OBD2 scan tool.
    You can check the obvious stuff like connections: electrical type and vacuum/intake related, but if the CE is on you need to find out why the computer is not happy.
     

Share This Page