Buy

355 speedo going backwards.

Discussion in 'Technical Q&A' started by chaa, Apr 23, 2004.

  1. chaa

    chaa F1 Veteran

    Mar 21, 2003
    5,058
    Took the 355 for a blast today, speedo went to 120 then went backwards to zero. No warning lights on and the car feels fine. Now at a stand still the speedo is reading 10mph as opposed to zero. Why?
     
  2. To remove this ad click here.

  3. Napolis

    Napolis Three Time F1 World Champ
    Honorary Owner

    Oct 23, 2002
    32,118
    Full Name:
    Jim Glickenhaus
    Probably faulty speedo sensor, loose wire, or cooked speedo in that order.
     
  4. Kds

    Kds F1 World Champ

    Now.....if it was a DeLorean......
     
  5. richard_wallace

    richard_wallace Formula 3
    Rossa Subscribed

    Feb 6, 2004
    1,952
    Cincinnati, Ohio
    Full Name:
    Richard Wallace
    Not sure on the going up to 120 than down...

    But all 355's that I have seen - when just parked - do not sit on Zero - it will be more like 10mph... When I got my 355 I also thought - why doesn't sit at zero... Couple of friends 355 - same thing... My thought is that the 355 looks like it is moving just standing still... The speedo sitting at 10 proves it :)

    Rich
     
  6. Wasco

    Wasco Formula Junior

    Dec 9, 2003
    486
    Salem
    Full Name:
    Randy
    It is my understanding from posts here and my own 78 308 that ALL older F-cars speedo's sit at 10 MPH in the garage!
     
  7. To remove this ad click here.

  8. chaa

    chaa F1 Veteran

    Mar 21, 2003
    5,058
    Good point richard, i think its becourse there is a problem that my focus was on the speedo, it very well could have sat at 10mph before i noticed it going backwards from higher speeds. Thanks.
     

Share This Page