News

360 360 Misfire Issue

Discussion in '360/430' started by Aeron Fout, Aug 1, 2020 at 9:28 AM.

  1. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    This morning I went to start my 2001 360 and it was running very rough and the check engine light was on. I shut it down and immediately smelled very rich fuel in the engine bay. It was throwing misfire codes for cylinders 1 thru 4.

    The car just had its major service about 1k miles ago including all new belts, intake gaskets, and spark plugs.

    I’m thinking this could potentially be an injector problem, but I think it’s more likely the ECU that runs cylinders 1 they 4. It seems strange to me that one entire side of the engine would misfire at one time.

    Just for information, the car was last ran about a week ago for a 50 mile drive and it was perfect. I would greatly appreciate anyone’s input or experience on this issue. Thanks


    Sent from my iPhone using FerrariChat.com mobile app
     
  2. KC360 FL

    KC360 FL Formula 3
    Silver Subscribed

    Jun 20, 2017
    1,067
    Melbourne Florida
    Full Name:
    KGC
    Coil packs? common but I didn't get any CEL.
     
    Aeron Fout likes this.
  3. flash32

    flash32 Formula 3

    Aug 22, 2008
    1,840
    Central NJ
    Full Name:
    Dominick
    Did you start too quickly and not wait for "ok" on dash



    Sent from my moto g(7) using Tapatalk
     
    Aeron Fout likes this.
  4. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    No, I just started it the way I always have.


    Sent from my iPhone using FerrariChat.com mobile app
     
  5. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    I don’t see how all four cool packs on one side of the engine could go bad at once.
     
  6. flash32

    flash32 Formula 3

    Aug 22, 2008
    1,840
    Central NJ
    Full Name:
    Dominick
    The reason I ask if that sometimes if you turn key on and not wait for "ok" and start ..one of the ECU may not "turn on" ..

    I would say try to start again but wait for "ok" and see if that helps

    By any chance is battery old and weak ?



    Sent from my moto g(7) using Tapatalk
     
    Skidkid and one4torque like this.
  7. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    I’ll give it a try and see if waiting a little longer on starting helps out. The battery is about 4 months old and always stays on a battery tender.


    Sent from my iPhone using FerrariChat.com mobile app
     
    flash32 likes this.
  8. S F

    S F Rookie

    May 13, 2016
    25
    Texas
    Just went through this. I had random misfires on an entire bank and a very rich running condition on half of the engine. It turned out to be the mass air flow sensor on my car. I went ahead and replaced both along with plugs and o2 sensors and it runs beautifully now.

    My Foxwell OBD2 scanner was able to show the mass air readings on both ECUs, in my case, one was reporting half of the airflow of the opposite bank which was causing all of my issues as the fueling was way off.
     
    Kevin Rev'n, one4torque and flash32 like this.
  9. KC360 FL

    KC360 FL Formula 3
    Silver Subscribed

    Jun 20, 2017
    1,067
    Melbourne Florida
    Full Name:
    KGC
    yup, sorry I read your post and thought you said 1 and 4, not 1 thru 4
    But with that said, I had 21K miles on my '03 360 and had a few going bad and replaced all eight. But again, no CEL just random misfires I could feel in the driver's seat.
     
    Aeron Fout likes this.
  10. one4torque

    one4torque Formula 3

    May 20, 2018
    1,705
    Houston
    Full Name:
    One4torque
    Highly likely mass air meter.

    try swapping a known good mas
     
    Aeron Fout likes this.
  11. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    Thanks for the info. I’m probably going to go ahead and replace the mass airflow sensors and o2 sensors.


    Sent from my iPhone using FerrariChat.com mobile app
     
  12. flash32

    flash32 Formula 3

    Aug 22, 2008
    1,840
    Central NJ
    Full Name:
    Dominick
    Before we start changing parts ..

    Start with the easy stuff ..starting properly.. pulling codes , check if the oil was over filled and caused maf to fail

    A good diag tool is needed if you want to see what is going on

    I do agree it can be the maf but a diag tool would tell you either in codes or data stream ..

    Considering you had a service ..could be a overfill which caused the maf to fail

    You can always move parts from one side to the other to see if that helps and narrow down part

    Sent from my moto g(7) using Tapatalk
     
    Skidkid likes this.
  13. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    I just swapped them side to side and it seems to have reversed the issue to the opposite bank. I’m going to order 2 new MAF sensors.


    Sent from my iPhone using FerrariChat.com mobile app
     
  14. flash32

    flash32 Formula 3

    Aug 22, 2008
    1,840
    Central NJ
    Full Name:
    Dominick
    Cool ..glad we were able to narrow it down .. was it oil that caused it ..did you see alot of oil residue ?



    Sent from my moto g(7) using Tapatalk
     
    Aeron Fout likes this.
  15. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    There was some oil residue on both sensors, but more on the misfire side. I’m going to pull the intake tubes off and see how much oil is inside the top of the manifold.


    Sent from my iPhone using FerrariChat.com mobile app
     
  16. Skidkid

    Skidkid F1 Veteran
    Rossa Subscribed Owner

    Aug 25, 2005
    6,111
    Campbell, CA
    Full Name:
    John Zornes
    Overfill on the oil causes oil getting into the intake. Oil and MAF don't mix and next thing you know, they are shot. Check the oil level engine warm and idling. Set the cap on the reservoir, don't screw it down. You wouldn't want to replace the MAFs only to ruin the new ones because you didn't chase down an overfill.
     
    Need4Spd, flash32 and Aeron Fout like this.
  17. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    Good advice. Thank you


    Sent from my iPhone using FerrariChat.com mobile app
     
  18. flash32

    flash32 Formula 3

    Aug 22, 2008
    1,840
    Central NJ
    Full Name:
    Dominick
    Exactly my thoughts ..

    Sent from my moto g(7) using Tapatalk
     
    Aeron Fout likes this.
  19. Need4Spd

    Need4Spd F1 Veteran
    Silver Subscribed

    Feb 24, 2007
    5,852
    Silicon Valley
    Even oil fumes too close to MAFS will degrade their performance without throwing codes.


    Sent from my iPhone using FerrariChat
     
  20. S F

    S F Rookie

    May 13, 2016
    25
    Texas
    Good deal. Did you order by the Bosch part numbers? I was able to get the pair for a little over $200 doing it that way. Substantial savings over ordering the Ferrari part numbers and the exact same units showed up.
     
  21. brookliner7

    brookliner7 Formula Junior

    May 5, 2018
    423
    San Antonio, TX
    Full Name:
    Hans
  22. Aeron Fout

    Aeron Fout Rookie

    Nov 21, 2019
    39
    Cocoa Beach, FL
    Full Name:
    Aeron Fout
    I haven’t ordered them yet. Who did you order yours from?


    Sent from my iPhone using FerrariChat.com mobile app
     
  23. S F

    S F Rookie

    May 13, 2016
    25
    Texas
    Rock auto was the best price I could find but recommend you look around as they’re probably all drop shipped from the same supplier.
     
    Aeron Fout likes this.

Share This Page