News

430 430 Exhaust OEM valves not opening

Discussion in '360/430' started by Paul Kane, Feb 23, 2021.

  1. Paul Kane

    Paul Kane Karting

    May 27, 2020
    136
    Rickmansworth UK
    Had the car on C Tec charger.
    Full power, started first push.
    Sun out so had to go for a trip, still cold wind though. Car stored in garage for 4 months.
    Get onto the motorway, booted it and no roar after 3000 revs. It was fine before being garaged.

    I presume my OEM exhaust valves are not opening.
    When exhaust had cooled down I found the 2 valves were free by pushing the rod in and out, they were squeaky but free.

    Any pointers to my problem?

    Thanks


    Sent from my iPhone using FerrariChat.com mobile app
     
  2. To remove this ad click here.

  3. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,371
    Uk
    Follow the 2 rubber hoses on the valves , i think they go to a solenoid
     
  4. SCKOMS

    SCKOMS F1 Rookie
    Silver Subscribed

    Oct 21, 2011
    3,428
    Lake County, IL
    Full Name:
    Spiro
    Check for vacuum on the hoses

    Sent from my Galaxy
     
  5. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,371
    Uk
    If you look on eurospares web site i think it shows the setup on the parts list, including the solenoid arrangement
     
  6. Paul Kane

    Paul Kane Karting

    May 27, 2020
    136
    Rickmansworth UK
  7. To remove this ad click here.

  8. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,371
    Uk
    Looking at the diagram there are 2 solenoid valves which get a signal to open the exh valves from the ecu. If neither of the exh valves are opening, then you have either lost the electric signal or you have no vaccum in the tank. It shows another solenoid valve between the engine and the vac tank so this might not be working, gives no vac and hence valves dont work. Take the pipe off and see if it sucks when engine running. You either have no vac or no electric signal. Might be a leaking pipe seal ring
     
  9. tazandjan

    tazandjan Three Time F1 World Champ
    Lifetime Rossa Owner

    Jul 19, 2008
    33,596
    Clarksville, Tennessee
    Full Name:
    Terry H Phillips
    F430 exhaust bypass valves are fail open. If they are not opening, you have vacuum all the time to keep them closed.
     
  10. gsworld2014

    gsworld2014 Formula 3

    Dec 23, 2014
    1,039
    South Florida
    Full Name:
    Greg S
    On of the solenoids might have went bad
     
  11. Paul Kane

    Paul Kane Karting

    May 27, 2020
    136
    Rickmansworth UK
    After playing around with the valves and solenoids with a fettle, poke and prod all is working again.
    Thanks all for your guidance.



    Sent from my iPhone using FerrariChat.com mobile app
     
  12. To remove this ad click here.

Share This Page