News

430 scuderia f1 pump

Discussion in '360/430' started by lauris, Sep 18, 2017.

  1. lauris

    lauris Formula Junior

    Jul 27, 2005
    281
    Glasgow
    Full Name:
    Scott Laurie
    Hi all,

    I have read loads of the threads on this and think I know what the problem is but interested in others opinion.

    2009 Scuderia, 14k mile

    Last year had high pitch screaming from the Rear RH,

    Sounded just like that,

    Led to belive its was the soleniod sticking and causing the pump to run constantly, it did it three of four times in total, (when in for service this year - asked them to check it out) couldnt find anything wrong but the relay was replaced.


    this year, have a simliar noise from same position but its much quieter and does it every 20 to 30 seconds or so around the time you are using the f1 paddle shift, then it goes away. also having some issues with fast changes, if you hit the paddle three of four times it doesnt always change to the desired gear, its like it runs out of pressure, leave it a second or two and then its ok,

    also when you start the car you have to selcect 1st, (or reverse) twice, it never goes in first time,

    also, occasionaly selects neutral when coming to junction instead of staying in 2nd and then changing to first, pain in ass this as you hit the gas an engine just revs.


    so kind assuming the electric motor and / or the hydraulic pump that it runs is losing pressure or the motor is losing power. so thinking of just replacing myself as its a bit of a pain to get to the dealer, (car has only been used 3 times this year) ans will due service in the spring,

    there seems to be talk on the threads of different part suppliers, certainly on ebay there are new units advertised as fits ferrar from £240, upwards, euro spares uk are about £600 and havent even checked what margin ferrari want for sticking a label on it and putting it in a ferrari box,


    just interested in peoples opinions that have swopped these out before and what they used,

    interested to know if its likely to the f1 motor or also the pump, as motor is a unbolt and bolt back on, if changing the hydraulic pump then the system has to be bled and that sounds more of a pain, ,,


    regards
    Scott.
     
  2. honda.vfr

    honda.vfr Karting

    Jun 22, 2012
    132
    Ostrava, CZ (EU)
    Full Name:
    Milan Pukl
    Try to check and/or replace the pump relay at first.
     
  3. mwstewart

    mwstewart Formula 3

    Feb 5, 2014
    1,584
    England
    Full Name:
    Mark
    You have a pressure issue but the root cause could be a number of things: accumulator, dead pump, internal leakage. It really needs diagnosing properly i.e. with a diagnostic tool.

    It is not the relay.
     
    TheCook likes this.
  4. lauris

    lauris Formula Junior

    Jul 27, 2005
    281
    Glasgow
    Full Name:
    Scott Laurie
    it was the pump,
     
    Zed82 likes this.
  5. kreh

    kreh Karting

    Feb 21, 2006
    216
    La Verne CA
    Full Name:
    Kim Reh
    Thanks for sharing your experience.
     
  6. Welikethetrack

    Dec 9, 2015
    15
    Austin
    Full Name:
    Leo Haury
    Anymore update on this? I had that same whine happen off and on for a 20 minute drive and when I stopped there was fluid all spilled on the back right of the car right next to the RR tire. Whats the exact issue? You replaced the pump and that fixed it?
     
  7. future328driver

    future328driver Formula 3
    Silver Subscribed

    Dec 10, 2001
    1,735
    Dallas, Texas
    Full Name:
    Ken Thomas
    Clear sign of the F1 pump failing. Experienced this on my 360 a few years back. In my case, the pump failed because the relay failed causing the pump to run constantly.
     

Share This Page