News

488 Pista/Pista Spider Battery Maintainer

Discussion in '458 Italia/488/F8' started by kansas488, Mar 25, 2020.

  1. kansas488

    kansas488 Karting
    Rossa Subscribed

    Jan 29, 2014
    118
    Kansas
    My gently used 2019 488 Pista Spider arrived this evening. I imagined it would need the battery maintainer plugged in tonight so I unpackaged it and connected it to the car, but the light sequence doesn't feel correct.

    When I attach the magnetic charger to the car, the green power light goes from solid to flashing, but no other lights display. I was expecting to see one of the lights along the status from 1 to 8 to be lit up, but none do. This is after more than an hour of charging.

    Is this normal behavior? It is that the battery was just very low and needs to charge overnight? Wanted to ask this group before I bother the dealer tomorrow morning :)

    Thank you (in advance) for your help! I don't live anywhere near a dealer so hoping nothing is wrong!
     
  2. nads

    nads Formula Junior
    Silver Subscribed

    Jun 4, 2008
    807
    London, UK
    Check to see if the magnetic connection to the car is clipped on properly. The flashing light would suggest it may not be, try to jiggle it slightly until it clicks into place properly. Hope that resolves the issue.
     
  3. kansas488

    kansas488 Karting
    Rossa Subscribed

    Jan 29, 2014
    118
    Kansas
    Thank you. I swear I thought I did that but sure enough went and moved it and the green light stopped flashing and the first two orange lights turned on (1&2). Hopefully that will be it. Was definitely getting nervous. Not a great sign in terms of how finicky it is. My 812 magnetic charger starts up every time without any jiggling.
     
  4. JohnTz

    JohnTz Karting

    Jun 21, 2018
    189
    Inverness, IL
    Full Name:
    John Tz
    The magnetic connection is VERY particular. It has to be perfectly aligned or it will not make a good connection. It’s not the best system for this. Especially if you want to put the cover on. Need to put a hole in the cover otherwise the connection is not strong enough and it gets knocked off.
     
  5. Carrerarsr

    Carrerarsr Karting

    Sep 29, 2014
    193
    Germany
    Full Name:
    Frank
    Thats exactly the problem. If you wanna use the cover you need to be careful with the connector. If you back the car into the garage you need more space to connect the charger. It is a stupid system ! Why not using a connector like in previous cars. This was done by an engineer who didnt know what to do so he made things worse !
     
  6. kansas488

    kansas488 Karting
    Rossa Subscribed

    Jan 29, 2014
    118
    Kansas
    yeah with my 488 GTB I snapped a black plastic curtain ring into the cover where the hole needed to be and then cut out the inside area. Worked great! I just ordered on of the embroidered covers so when it comes I will do the same. I'm just glad it was user error!
     
    Melvok likes this.
  7. Melvok

    Melvok F1 World Champ
    Rossa Subscribed Owner

    Jul 25, 2008
    12,960
    Amersfoort, Holland.
    Full Name:
    Mel
    Many have done so: cut a hole in that panty !
     

Share This Page