News

Cali T - battery light

Discussion in 'California/Portofino/Roma' started by James cln, Dec 4, 2019 at 4:46 PM.

  1. James cln

    James cln Karting

    Dec 20, 2015
    145
    San Antonio
    Full Name:
    James cline
    Well the red battery light is on again - driving me crazy! Had battery ( proper AGM) completely checked leak down, cranking amps etc by interstate dealer- checks fine . Alternator charges at 14.7 at start up then drops back to 14 or so . After charging overnight or longer - proper CTeK that came w car - green light on charger . After starting - red battery light on dash .
    Battery stays charged , everything works fine . I watch volts on dash and looks great but still this irritating red light - I did hard reset twice to no avail - it did go out on one drive but came back on next day. Help! Can anyone tell me what is the problem?? Could it be maybe in instrument cluster giving a false indication ? Or ??? Thanks , james
     
  2. tomc

    tomc F1 World Champ

    Apr 13, 2014
    17,530
    DFW, Texas
    Full Name:
    Tom C
    Sorry to hear this. What battery conditioner are you using? The one that came with the car? Could it be that your conditioner is starting to fail? When I got my Cali, I had some odd TFT messages. Replaced the battery and bought a new CTEK 7020 conditioner, and knock on wood, been behaved since then...T
     
  3. James cln

    James cln Karting

    Dec 20, 2015
    145
    San Antonio
    Full Name:
    James cline
     
  4. James cln

    James cln Karting

    Dec 20, 2015
    145
    San Antonio
    Full Name:
    James cline
    Yep it’s the proper conditioner for the T . Conditions battery completely- even reset it several times . Even starting w fully charged battery and driving 30 miles light stays on - wahhh . Voltage shows perfect from alternator and when car is turned off after drive over 12.5 volts from battery . :-( thanks for helping :)
     

Share This Page