News

Distorted and Crackling Stereo Sound 1999 456 MGTA

Discussion in '456/550/575' started by ihassan, Oct 21, 2020.

  1. ihassan

    ihassan Rookie

    Jul 8, 2007
    23
    Southern California
    I have a factory 1999 456 MGTA with no mods. Recently, the car audio gets distorted with very little bass response and a noticeable crackling sound. Low volume levels don't seem to present a problem but increase the volume and the sound gets distorted. I thought it could have been a blown speaker but I don't think all the speakers would blow simultaneously. Does the 456 have a subwoofer? Any suggestions on what the problem might be?
     
  2. To remove this ad click here.

  3. Fennicus

    Fennicus Formula Junior

    Apr 10, 2015
    523
    Helsinki, Finland
    Full Name:
    Pekka T.
    Hi,

    Ferrari called the bass speakers in the rear seat footwells for ”subwoofers”. The foam turns to dust over time, they can be repaired or replaced.

    Also I believe the ”M” uses a different main unit (radio, control and front channels amp) but at least the Sony unit on my 1995 456GT did exactly that until I had it refurbished. A dozen of capasitors were blown, possibly due to heat in the trunk, and time. Now it works perfectly and sounds pretty good IMO. I wrote about it as posted some photos in one of the 456GT stereo upgraded threads in here.

    Cheers!
     
    Qavion likes this.
  4. killer58

    killer58 Formula 3

    Jun 30, 2010
    1,142
    CA & DC
    +1
    That would be where I’d start.
     
  5. ihassan

    ihassan Rookie

    Jul 8, 2007
    23
    Southern California
    So does the head unit (main radio) come out and get refurbished or is there a separate amplifier in the trunk? In either case, is there a recommended vendor that refurbishes the main head unit and/or amp?
     
  6. ihassan

    ihassan Rookie

    Jul 8, 2007
    23
    Southern California
    Did you send the Head Unit out for repairs and if so, where?
     
  7. To remove this ad click here.

  8. Fennicus

    Fennicus Formula Junior

    Apr 10, 2015
    523
    Helsinki, Finland
    Full Name:
    Pekka T.
    #6 Fennicus, Oct 24, 2020
    Last edited: Oct 24, 2020
    Hi,

    I did, but as I am in Finland I had it done relatively locally (had to ship the whole thing, to another city, but within this country) I am sure if you are in the US that there are similar shops that repair vintage electronics and stereos over there.

    This is the company that did it: https://pulttikanava.fi/tuoteryhmat/elektroniikka-ja-huolto-osasto
    I have used them before also for repairing (instead of replacing with odd modern technology) and refurbishing my 1975 Audiovox Quadraphonic (Q8) surround stereo 8-tarck cassette deck and FM radio, and a home Akai CR-80SS 8-track Quadraphonic recording and playback deck as well as charging control units and Lucas OPUS Mk.2 ignition units on my V12 E-type and other car electronic components.

    They also refurbished my 456GT front seat ECU but it did not cure the problem in my drivers seat, which must be the seat position potentiometer as everything else has been checked and works correctly. (Another thread on the 456 GT front seats can easily be found here on the forum).

    That's just your basic old school stereo and electronics repair shop, but the Sony unit, nor any other unit from the 1970's, 80's or 90's is any rocket science. I have the repair bills and the changed components. Form memory I can say that it was mostly small blown capacitors in the main unit that was the issue with all front channels.

    Cheers!

    Ps. I sent the control unit, the cable from the control unit to the main unit in the trunk, the main unit, the amp and the CD changer. The amp was fine (only the two rear channels) the main unit needed serious work and the CD changer was unrepairable for now, due to lack of parts, the lens control unit was dead, but I got another 10 CD working Sony Unilink CD changer that fits in there for €50,00 euros. I wrote a thread about it with photos as I added two thermo controlled large fans in there to cool the main unit down as it gets pretty hot in there inside the trunk. In the summer I can sometimes hear the fans with a small humm coming from behind the LH side C-pillar when sitting in traffic lights etc. so I know they work.

    It was in this thread: https://www.ferrarichat.com/forum/threads/1992-1998-ferrari-456gt-and-456gta-stereo-guide-ipod-and-more.222934/page-3
     

Share This Page