News

F12 right display help

Discussion in 'FF/Lusso/F12/812S' started by Alcav5, Mar 23, 2019.

  1. Alcav5

    Alcav5 F1 Rookie
    Rossa Subscribed Silver Subscribed

    Jul 28, 2012
    2,967
    Scarsdale, NY
    Full Name:
    Al
    I'm sitting in my F12, wanting to drive home 2.5hrs listening to music and my right display only wants to show me mph . I can't get the radio working, pressed all the buttons, I can't figure it out, I can't get to my manual.
    Anybody?

    Grazie
     
  2. To remove this ad click here.

  3. richard_wallace

    richard_wallace Formula 3
    Rossa Subscribed

    Feb 6, 2004
    1,950
    Cincinnati, Ohio
    Full Name:
    Richard Wallace
    Try pushing the botton on the back of the steering wheel. Has an up and down toggle (channel) and the middle push button is the source. Maybe you have it on the wrong source.

    Or you may have to stop, turn the car off, pull the key out, then put the key in, and then restart. Could be frozen system....
     
  4. richard_wallace

    richard_wallace Formula 3
    Rossa Subscribed

    Feb 6, 2004
    1,950
    Cincinnati, Ohio
    Full Name:
    Richard Wallace
    The botton which I refer is on the back of the steering wheel is on the right side btw...
     
  5. Alcav5

    Alcav5 F1 Rookie
    Rossa Subscribed Silver Subscribed

    Jul 28, 2012
    2,967
    Scarsdale, NY
    Full Name:
    Al
    Thx

    I tried what you said , no good.
    I had turned the car on & off a couple times
    I lost operations of the radio controls, no bluetooth, can't do phone, so that system is off,,, sounds like it need professional attention, coincendly the car needs to go in for air bag recall
     
  6. SVCalifornia

    SVCalifornia Formula 3

    Mar 28, 2011
    2,139
    Silicon Valley
    Full Name:
    Keith
    Sounds li’e it needs a full power reboot. Pull the battery.

    Or pull the right fuse...

    SV


    Sent from my iPad using Tapatalk
     
  7. To remove this ad click here.

  8. monkiboy48

    monkiboy48 Rookie

    Feb 22, 2012
    12
    Hawaii
    Full Name:
    Chad
    You have to press and hold down one of the buttons below the right screen. I forget which one but I believe it is the “back” button you need to press and hold.

    Good luck!
     
    4_Eff_Sake likes this.
  9. Ferro458

    Ferro458 Karting

    May 26, 2014
    171
    I have one of these cars, and this part of it gets flakey on a regular basis. Turn it off, wait...sometimes it just resets itself.
    Or, the battery may be dying, another issue.
     
  10. Alcav5

    Alcav5 F1 Rookie
    Rossa Subscribed Silver Subscribed

    Jul 28, 2012
    2,967
    Scarsdale, NY
    Full Name:
    Al
    I'm thinking its the battery.
    I held down buttons, two at a time, all sorts of fooling with , nothing.
    In left screen with those controls you can "set car up". There is also a feature to address right screen for mph digital or spedo, probably should have been radio display option. I think I lost option for radio display, I bet i lost connectivity to radio, including bluetooth & phone.

    I'm not fooling with it, will wait to get it into dealer. still drives like an owner... :)
     
  11. unotaz

    unotaz Formula Junior

    Jun 4, 2006
    457
    Los Angeles
    Full Name:
    Michael
    If you have Apple CarPlay, then press the volume button on the right control command and hold it for 10secs, it will reset the system.

    If you don't have Apple CarPlay, then press the Main/Back button on the right control command and hold it for 10 seconds, it will reset the system.

    Image Unavailable, Please Login
     
    Solid State, ScottS and 4_Eff_Sake like this.
  12. To remove this ad click here.

  13. Alcav5

    Alcav5 F1 Rookie
    Rossa Subscribed Silver Subscribed

    Jul 28, 2012
    2,967
    Scarsdale, NY
    Full Name:
    Al
    No good, thx anyway, seems like I lost radio, telephone, even clock display, even though time is correct when I go to car set up
     
  14. Adamas

    Adamas F1 Veteran
    Rossa Subscribed

    Jan 13, 2012
    5,919
    Out of town
    Full Name:
    Mike
    Have you tried swearing at it ?

    That's usually how I start troubleshooting, and then if that doesn't work, I proceed from there.

    Mike
     
  15. WilliamB

    WilliamB Karting

    Feb 1, 2017
    240
    Switzerland
    Full Name:
    William
    It also can happen when the car needs its maintenance / system update ... looks like it forces you to go to your car dealer to have it done :)
    A friend told me that exactly that happened to him and after the update all was back to normal!
     
  16. Solid State

    Solid State F1 Veteran
    Rossa Subscribed Owner

    Feb 4, 2014
    6,074
    Full Name:
    Nosmo King
    At this point its back to the dealer or battery disconnect reboot. The disconnect/reconnect procedure is in the manual and it must be at least 41 degrees F (5 degrees C) ambient temperature and there is a specific initial startup procedure you must follow to sync up the ECUs. Easy once you know how.
     
  17. luis cuadrado

    luis cuadrado Rookie

    Jul 5, 2020
    2
    Full Name:
    Luis cuadrado
    #14 luis cuadrado, Aug 27, 2020
    Last edited by a moderator: Aug 27, 2020
    Hello , sorry , how did you fix the problem? I am facing the same one... thank you
     
  18. Alcav5

    Alcav5 F1 Rookie
    Rossa Subscribed Silver Subscribed

    Jul 28, 2012
    2,967
    Scarsdale, NY
    Full Name:
    Al
    Some posters said all they needed to do was reset the radio . If I remember correctly you can reset the radio yourself , I do not remember the process.

    In the end for me , it turned out the radio head unit was bad , they replaced it , was over $8,000 , I think there may be another separate thread here on it.

    Good luck
     
  19. luis cuadrado

    luis cuadrado Rookie

    Jul 5, 2020
    2
    Full Name:
    Luis cuadrado
    Thank you so much.
     

Share This Page