News

Gas flap problem fixed

Discussion in '348/355' started by ferraridriver, Apr 4, 2008.

  1. ferraridriver

    ferraridriver F1 Rookie
    Rossa Subscribed

    Aug 8, 2002
    4,092
    Bay Area Calif.
    Full Name:
    Dave
    I had posted a while ago about replacing the OEM connector at the gas flap solenoid with T&B spade wire ends.

    I can now say after several months testing that the OEM connector was the culprit.

    Before changing the connector I had cleaned and applied Stabilant, that lasted about a month then it was back to manually opening the flap.

    I wonder how many solenoids have been replaced when corroded terminals in the connector was actually the problem.

    My gas flap now opens every time.
     
  2. To remove this ad click here.

  3. gothspeed

    gothspeed F1 World Champ

    May 26, 2006
    10,244
    U.S.A.
    Full Name:
    goth
    Great post............. it makes sense in that corroded terminals could not carry the neccessary current to power the solenoid.

    I have mentioned before that I took every connector/relay/fuse I get my hands on and put a corrosion inhibitor on those interfaces. It does nothing but good as voltage/current can flow better throughout the electrical system. :)
     
  4. UConn Husky

    UConn Husky F1 Rookie

    Nov 11, 2006
    4,416
    CT
    Full Name:
    Jay
    Great info Dave, I'll have to check mine. Although it is kind of cool to pull up to the gas station and open the engine cover to pop the gas cap...
     

Share This Page