News

HELP 512BBi with no power?

Discussion in 'Technical Q&A' started by DJW, Dec 19, 2003.

  1. DJW

    DJW Karting

    Oct 19, 2001
    197
    NJ
    never had anything remotely like this before.

    let a friend and a passenger drive my boxer, when i got in to go home, there was a severe drop in power. the only guess i have, is that something clogged the injection, because i was real low on gas.
    Is there any DIY method to troubleshoot. alos the idle is lower than it was. had been idling around 1600, now at 1200 without the power.
    any help would be appreciated.

    david
     
  2. henryk

    henryk Formula Junior

    Dec 9, 2003
    479
    Door County, WI
    I would pressure test the injectors, and check the spray pattern. If they are bad, then I would suggest removing the gas tanks and cleaning them out, also the injection lines and distributors........then replace all injectors, and fuel filters.

    It would seem that you had a problem before this. My BBi idles at 1000 RPM. 1600 is way too high, as is 1200 RPM.
     
  3. Dave

    Dave F1 Rookie

    Apr 15, 2001
    2,722
    Little Rock
    Full Name:
    David Jones
    Hi DJW, I might check to see if they didn't foul out a spark plug or two...

    DWJ
     
  4. Steve Magnusson

    Steve Magnusson F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    18,156
    Texas
    Full Name:
    Steve Magnusson
    (Gotta agree with Hank and say that a K-Jet warm-idling at 1600 RPM needs some fondling regardless, but) "Severe loss in power" (yet running quasi-smoothly) is a classic symptom of 1-bank dead in the injected flat-12 architecture. I'd start with a simple spark test on each bank, (if passed) then a simple fuel test on each bank (e.g., I'm sure one the BB owners could describe how to induce each FP to run independent of the engine running so you could at least do the "audio" FP test) -- good luck with the beast...
     
  5. parkerfe

    parkerfe F1 World Champ

    Sep 4, 2001
    12,887
    Cumming, Georgia
    Full Name:
    Franklin E. Parker
    Yet another reason why one should not let others drive their Ferrari. My BB512i idles at 1000rpm or so too. Even the cold start idle is less than 1600rpm. I would look at the cold start circuit as it could be flooding the car causing plugs to foul. If that is OK, check the injectors next. The timing could be off too which can cause a high idle and low power. Good luck.
     
  6. petec

    petec Rookie

    Nov 16, 2003
    5
    Kansas City, MO
    Full Name:
    Peter Cipolla
    Make sure both fuel pumps are working properly. Had the same issue. Only one of the fuel pumps was operating. The car will run on one and actually do ok just clearly with less power.
     
  7. Steve Magnusson

    Steve Magnusson F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    18,156
    Texas
    Full Name:
    Steve Magnusson
  8. jselevan

    jselevan Formula 3

    Nov 2, 2003
    1,849
    Steve M. - always nice when someone appreciates your input. I will prepare a white paper on the fuse I squared R losses and post it in the techniical section. Thanks.

    Jim S.
     
  9. DJW

    DJW Karting

    Oct 19, 2001
    197
    NJ
    thanks all for the advise, i've got a few good starting points.

    David
     
  10. parkerfe

    parkerfe F1 World Champ

    Sep 4, 2001
    12,887
    Cumming, Georgia
    Full Name:
    Franklin E. Parker
    Most Ferrari repair shops in the know routinely solders all connections in new fuse boxes they install in Boxers and 308s due to the overheating problem mentioned by Seleven. When I had an intermittant cooling fan problem in my Boxer, it turned out to be a partially melted fuse box and FoA soldered all connections in the new one before installion. I was told that that had been being done since the late 1970s.
     

Share This Page