News

Indicator Trouble

Discussion in 'United Kingdom' started by barabus, Jun 19, 2005.

  1. barabus

    barabus F1 Rookie

    Aug 22, 2004
    4,777
    12 Cylinder Village
    Full Name:
    Si
    Yesterday on the way home my drivers side indicators started flashing too fast.

    On inspection the rears are not working but the bulbs are fine.

    Have checked all fuses they're fine.

    I don't know too much about electrics, anybody any ideas.

    PS I reallise on such a lovely day most of you are out, I wish I was:(
     
  2. To remove this ad click here.

  3. F328GTS

    F328GTS Formula 3

    Apr 27, 2004
    1,628
    Cambridgeshire, UK
    Full Name:
    Nigel R
    If they flash at double speed it's normally a bulb gone. As it is on the drivers side, have you checked front and back bulbs on that side? Do they both come on?
     
  4. barabus

    barabus F1 Rookie

    Aug 22, 2004
    4,777
    12 Cylinder Village
    Full Name:
    Si
    Rears not coming on but bulbs are good, I'm flummuxed:(
     
  5. F328GTS

    F328GTS Formula 3

    Apr 27, 2004
    1,628
    Cambridgeshire, UK
    Full Name:
    Nigel R
    Have you swapped bulbs with the other side?
     
  6. barabus

    barabus F1 Rookie

    Aug 22, 2004
    4,777
    12 Cylinder Village
    Full Name:
    Si
    Put new bulbs in.....no change:(
     
  7. To remove this ad click here.

  8. stevew

    stevew Formula 3

    Jun 9, 2002
    1,837
    uk
    Full Name:
    Steve
    Check & clean connections esp earths.
     
  9. steve f

    steve f F1 World Champ

    Mar 15, 2004
    12,030
    12cylinder town
    Full Name:
    steve
    well you are old enough to remember hand signals so stick your arm out of the window for right turns and have a passenger for left turns

    it could be a bad earth try earthing out the rears
     
  10. barabus

    barabus F1 Rookie

    Aug 22, 2004
    4,777
    12 Cylinder Village
    Full Name:
    Si
    Will do but i'm overheating now, thats me NOT the car :D

    Used hand signals on me test, well they only had those sticky out trafficators then:D:D
     
  11. barabus

    barabus F1 Rookie

    Aug 22, 2004
    4,777
    12 Cylinder Village
    Full Name:
    Si
    Would you Adam and Eve it, I fiddled and diddled and now they work:D

    Thing is now my headlights DONT pop up:confused:
     
  12. To remove this ad click here.

  13. Hud

    Hud F1 Veteran
    Lifetime Rossa

    Jan 26, 2005
    6,353
    UK
    Full Name:
    Rob
    We had the same indicator prob on the 550. Turns out dad had got some water into the electrics when washing it. Fine once it dried out.
     

Share This Page