Buy

mondial odometer like a slotmachine! crazy problem

Discussion in 'Mondial' started by BlackMondial32, Nov 14, 2012.

  1. BlackMondial32

    BlackMondial32 Karting

    Aug 27, 2007
    244
    thats a strange incredible problem on my mondial 88 3.2

    i insert the key and when i turn the key on , (position two,before the turn on engine)
    the upper odomoter start to count!! 1,2,3,meter 10,20, and increase the general mileage
    and its sooo fast!!
    yesterday i try to check the fuse box, the car jump 1000 km just parked!!! thats insane!!

    when i turn on on position 3 and start the engine, everthings work, but the partial odometer count fast too!!!

    car are very pristine 49800 original km, two owners, (me included) keep in the garage and serviced for all his life!

    i suspect two problems

    1) electrical problem inside dashboard instruments (hell to disassembling)
    2) speedometer sensor on transaxle send crazy signals (but rpm and speed working while odometer running like slotmachine)

    somebody can help me ?
     
  2. To remove this ad click here.

  3. ronfrohock

    ronfrohock F1 Rookie
    Rossa Subscribed Owner

    Aug 16, 2004
    3,386
    MA
    Full Name:
    Ron Frohock
    I've never heard of this issue.
    Sounds like your odometer is now a Hobbs meter......
    I can't wait to see what comes of this.
    Paging Dr. Magnusun. (Sp?)
     
  4. thecarreaper

    thecarreaper F1 World Champ
    Silver Subscribed

    Sep 30, 2003
    16,679
    Savannah
    Actually I have heard of this. One of my QV's had its odometer repalced as it was said it would run its km up while parked for weeks at a time with the battery on a tender. Not sure what else would cause this but my former car was fixed and had a disclaimer with it about the odometer / speedo issue. Crazy Italian electrics :)
     
  5. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
    #4 afterburner, Nov 15, 2012
    Last edited by a moderator: Sep 7, 2017
    My odo also jumps 1 increment, once, when I turn the ignition key from OFF to the first position. Since your speedo is working, the sensor is not the issue. My guess is that there is internal fault to the odo that doesn't stop it from turning despite not receiving a signal from the sensor. Maybe the attached diagram can help your troubleshooting.
    Image Unavailable, Please Login
     
    Qavion likes this.
  6. BlackMondial32

    BlackMondial32 Karting

    Aug 27, 2007
    244
    todayi disassembled the dashboard and instruments!!!!!
    tomorrow i will post it some pictures
    i found the threads and the connector

    i suspect that odometer signal counter is out of control and self start

    somebody have the schematics of the odometer?
     
  7. To remove this ad click here.

  8. dmcleod

    dmcleod Rookie

    May 2, 2021
    38
    Toronto, Ontario
    Full Name:
    Derek McLeod
    Reviving this thread from the dead as I have the exact same problem in my 88' Mondial.

    Did this ever get resolved?
     
  9. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
    OP: If you remove your milage counter/clock unit here the wire colors/functions so you know what you are looking at:

    black: permanent ground for clock and milage counter
    blue red: permanent 12V (for the clock)
    green white #1 : switched 12V in for the clock (shows time)
    green white #2 : switched 12V out to the speed impulse sensor
    red black: speed impulse sensor signal via the speedo (direct, you can disconnect the speedo and still count the miles)
    yellow: lights ON 12V, input for the rheostat and dims the clock
    yellow purple: dimmed output to all the instruments lights
    blue: unused on your car, it triggers the service milage counter not present on your car
     
  10. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
    I would take the unit out and have a good look at it. If your speedo works the sensor and related circuit is good, you have power and ground else your clock and counters wouldn't work. My best guess is that the stepper motor gets permanent 12V instead of the trigger from the sensor. Open up the unit see if anything is weird/burned/not-original by a previous owner who tried to improve things...
     
  11. theunissenguido

    theunissenguido Formula 3
    Silver Subscribed Owner

    Jan 21, 2004
    1,889
    Argent/Brasil
    Full Name:
    Guido
    I love that frase : a previous owner who tried to improve things...:p
     
    ronfrohock likes this.
  12. To remove this ad click here.

  13. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,774
    Uk
    49800 kms- shortly to become 65000 if u keep turning the key- has to be the oddest problem i have come across on here-
     
  14. dmcleod

    dmcleod Rookie

    May 2, 2021
    38
    Toronto, Ontario
    Full Name:
    Derek McLeod
    I agree - an odometer should be the most reliable thing on any vehicle!
     
  15. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
    It's not an odometer problem, you guys just don't understand how fast Mondials are!
     
  16. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,774
    Uk
    I know what you mean, i could never keep up with mine when pushing it down the road to bump start it.
     
    afterburner likes this.
  17. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
  18. afterburner

    afterburner F1 Rookie
    Silver Subscribed

    Jun 20, 2008
    2,673
    Hong Kong
    STMicroelectronics BD140 PNP Transistor, 3 A, 80 V, 3-Pin SOT-32 - would that work?
     
  19. 83Mondialqv

    83Mondialqv Karting

    May 18, 2021
    175
    New York
    Full Name:
    Vito L
    So my miles stopped working too my tachometer and Speedo work fine. My mechanic said it could be the speedo sender I’m assuming he meant to say speedo sensor? Any know what he could me goal king about


    Sent from my iPhone using FerrariChat.com mobile app
     

Share This Page