Need help fixing 458 ctek battery tender dongle | FerrariChat

Need help fixing 458 ctek battery tender dongle

Discussion in '458 Italia/488/F8' started by DefunctNeurons, Jan 21, 2023.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, Skimlinks, and others.

  1. DefunctNeurons

    DefunctNeurons Formula Junior

    May 15, 2018
    412
    Alpharetta, GA
    Full Name:
    Trevor
    The battery tender plug that goes into the lower dash had a wire pull out of it, and I can't figure out which of the two remaining wire holes it needs to go back into. There are two wires for the proprietary plug, a red and a black. The black one is in hole 1 and the red one should be in 2 or 3 (see pics).

    Any ideas on how to fix or which hole red goes in? Or even where I can get a replacement dongle (can't find one now).
    Image Unavailable, Please Login Image Unavailable, Please Login Image Unavailable, Please Login
     
  2. Melvok

    Melvok F1 World Champ
    Owner Silver Subscribed

    Jul 25, 2008
    14,146
    Amersfoort, The Netherlands, Europe.
    Full Name:
    Mel
  3. Boiler Inspector

    Boiler Inspector Formula Junior
    Silver Subscribed

    Oct 14, 2017
    312
    Texas
    Full Name:
    Brian
  4. DefunctNeurons

    DefunctNeurons Formula Junior

    May 15, 2018
    412
    Alpharetta, GA
    Full Name:
    Trevor
    Thanks, don’t use eBay anymore these days so I forget about it. Hopefully these work. I think I’m still going to fix mine so I have a backup. Much appreciated Bob!

    Trevor


    Sent from my iPhone using FerrariChat
     
  5. DefunctNeurons

    DefunctNeurons Formula Junior

    May 15, 2018
    412
    Alpharetta, GA
    Full Name:
    Trevor
    Not sure how to interpret that except as “either one would work”. Sound correct?


    Sent from my iPhone using FerrariChat
     
  6. DefunctNeurons

    DefunctNeurons Formula Junior

    May 15, 2018
    412
    Alpharetta, GA
    Full Name:
    Trevor
    Follow up: I purchased the charger adapter as linked above and it finally arrived this week. Didn't work at first but I had an extension cable from CTEK I was previously using. When I removed the extension the new adapter worked just fine. Thanks all!!
     

Share This Page