News

355 Rear Parking Brake Cable jammed and won't come off at mechanism in hub.

Discussion in '348/355' started by AutoFanaticF355, Dec 11, 2020.

  1. AutoFanaticF355

    AutoFanaticF355 Karting

    Aug 13, 2020
    52
    NY
    Full Name:
    Philip
    As I continue the restoration of my suspension and brake systems I am replacing the original rear parking brake cable and sending the tapered sleeves out for cad plating. I spent over two hours tonight in frustration It seems the clevis on the mechanism is jammed or modified and I can not get the cable to unhook itself. with the wheel bearing and shoe assembly still mounted there is not much access to see and stick something in there to pry it off. I released the slack from the adjuster nut that is mounted on the drivers rear subframe arm but its stuck. I just searched some old threads and see someone used a plastic cable tie to modify the clevis to keep it from coming off. I hope my car did not have something similar done but you new know after all these years

    I am trying to avoid yanking the axle and wheel bearing and tearing it all down so if anyone has any tricks on doing this please post in this thread.
     
  2. To remove this ad click here.

  3. Pangea

    Pangea Formula Junior

    Mar 27, 2011
    403
    UK
    Full Name:
    Nick
    That was probably me with the zip tie. Cant see you succeeding without removing the brake shoes. Its a fiddly job but can be done with the hub etc left on.
     
  4. AutoFanaticF355

    AutoFanaticF355 Karting

    Aug 13, 2020
    52
    NY
    Full Name:
    Philip
    Its still wont budge i think my issue now is the spindle is resting on a jackstand and i need to wait until i bolt the refinished wishbones back on so i can tug the crap out of things as it sits now its just too hard with the spindle flopping all over.
     

Share This Page