News

Speakers

Discussion in '456/550/575' started by motts, Jun 20, 2018.

  1. motts

    motts Karting

    Sep 1, 2015
    106
    Denver
    Full Name:
    Alex
    Good morning. Looking to replace my speakers in the 550 mine are old and cracked. Not looking for anything fancy just bolt on replacement. Anyone the correct sizes.
    Thanks.
     
  2. stevepaa

    stevepaa Formula Junior

    Apr 5, 2006
    509
    san jose, ca
    Full Name:
    steve
    try audison APX 5 COAXIAL for rears, the FOCAL PC-130F WILL NOT FIT
    you can have my original ones from my 2002 575 if you want. I think they still have life in them
     
  3. motts

    motts Karting

    Sep 1, 2015
    106
    Denver
    Full Name:
    Alex
    Thank you!
     
  4. motts

    motts Karting

    Sep 1, 2015
    106
    Denver
    Full Name:
    Alex
    Replaced the rear speakers with a pair of Critical Mass RS57 easy fit very light with neo magnets and SS5 fronts. They sound great.
     
    paulchua likes this.
  5. hwyman

    hwyman Karting

    Jun 25, 2015
    173
    Canada / Los Angeles
    When swapping speakers in the 550, are the wires with the white stripe negative or positive poles? I put one Focal 4" in the front left location just to see whats involved. I soldered the OEM plug off the destroyed Ferrari speaker to the mid woofer crossover in the Focal kit (save the OEM plug in the car). The Focal speaker is way quieter than OEM.. hoping once I get all 4 in with the amp it will wake up
     
    paulchua likes this.
  6. paulchua

    paulchua Cat Herder
    Moderator Owner

    Jul 1, 2013
    7,634
    Menlo Park, CA
    Full Name:
    Paul Chua
    Hang tight @hwyman I'm about to swap out my head unit this week. I'll take a photo for you.

    Stay tuned.
     
  7. hwyman

    hwyman Karting

    Jun 25, 2015
    173
    Canada / Los Angeles
    I got my front focals in and the amp. Amp fits right in the center console and the harness plugs inline with the oem connectors. Sounds awesome. Last step will be the rear speakers
     
    paulchua likes this.
  8. paulchua

    paulchua Cat Herder
    Moderator Owner

    Jul 1, 2013
    7,634
    Menlo Park, CA
    Full Name:
    Paul Chua
    I think the wires is as follows:
    What I plan to do is crimp the wires from the factor slot and follow the arrangement.
    Image Unavailable, Please Login
     
    tres55 likes this.
  9. timeckart

    timeckart Formula Junior

    Apr 9, 2015
    488
    Wildeck in Germany
    Full Name:
    Tim Eckart
    I have a Kenwood radio in my Maranello 550. After the winter break without electricity, the radio only displayed Protect. No sound. An identical Kenwood only indicated Protect. A new Blaupunkt radio shows the stations, but there is no sound from the speakers. Does somebody has any idea?
     
  10. paulchua

    paulchua Cat Herder
    Moderator Owner

    Jul 1, 2013
    7,634
    Menlo Park, CA
    Full Name:
    Paul Chua
    Wow, that's crazy. Has it ever worked?
     
  11. paulchua

    paulchua Cat Herder
    Moderator Owner

    Jul 1, 2013
    7,634
    Menlo Park, CA
    Full Name:
    Paul Chua
    Okay just finished the deck install (speakers are shot, so doing that next)

    Hope this helps,

    1999 MGTA Speaker Wire colors

    Green = Right Rear Positive
    Green/Black = Right Rear Negative
    Black = Right Front Positive
    Gray/Blue = Right Front Negative
    ---------------------------------------------------------
    Gray/Blue (yes, same as color as Right Front Negative...go figure) = Left Front Positive
    Black/Red = Left Front Negative
    Gray/Red = Left Rear Positive
    Black/Gray = Left Rear Negative
     
  12. timeckart

    timeckart Formula Junior

    Apr 9, 2015
    488
    Wildeck in Germany
    Full Name:
    Tim Eckart
    Yes the radio always did. At first I thought Protect is called Pin Code Entry. But it means that a speaker has a short circuit. I can not imagine that. Maranello problems are actually always the same. I'm having trouble with the fuse box. Securing the fog lights with license plate lighting and instrument lighting creates problems. Then I open the fuse box and it goes again .... What is broken with the speakers? I know that from my Rolls-Royce. The membrane tear. I was hoping that it was a backup problem or bad contact ... or an underpowered problem
     
  13. tres55

    tres55 Formula 3
    Rossa Subscribed

    Sep 18, 2012
    2,228
    Canada
    Pioneer P80PRS
    Focal 570AC 5X7" - Rear Shelf
    Focal Access 100AC - 4" - Front Kick Panels

    This is what I put in mine. Both fit in factory locations without any modifications. The kick tweeters needed some washers to push the speaker a bit further back from the carpet, but they fit. I didn't get to replace the tweeters in the dash as apparently the dash needs to come out...hence why I went with 2way coax speakers. Ideally would have loved to do components...maybe will revisit the setup in the future if I need to recover my dash or something.

    I also purchased the Focal iBus20 - 8" powered slim profile subwoofer which I plan on mounting behind the passenger seat wall at some point.

    My factory speakers were toast. I kept them but they're pretty much completely deteriorated. Can't imagine anyones at this point are holding up well...they look very cheaply made.
     
  14. hwyman

    hwyman Karting

    Jun 25, 2015
    173
    Canada / Los Angeles
    Yeah my OEM speaker surrounds were toast too. I used 5.25 components in a mounting plate made by Focal to replace the 5x7's. I hear you on the front tweeter, they sound ok but the OEM speakers use way less power so the tweeters always run a bit hotter. Discount stereo can make you a harness to plug your aftermarket deck into the oem plugs, saves modifying the oem wiring. The Blaupunkt plugged straight in, zero modifications.
     
  15. hwyman

    hwyman Karting

    Jun 25, 2015
    173
    Canada / Los Angeles
    When you wired speakers did you use the wire with the stripe as positive or negative pole?
     
  16. tres55

    tres55 Formula 3
    Rossa Subscribed

    Sep 18, 2012
    2,228
    Canada
    I can't remember now but I had to look it up because I was confused for a minute. There's a thread here somewhere that addresses the topic.
     
  17. tres55

    tres55 Formula 3
    Rossa Subscribed

    Sep 18, 2012
    2,228
    Canada
    Mine already had an old Pioneer in it. The harness was really old and different from the new one so I had to rewire it. Not a big deal pretty straightforward.
     

Share This Page