News

2004 360 Alarm module failure

Discussion in '360/430' started by Scotter, Dec 8, 2013.

  1. Scotter

    Scotter Rookie

    Apr 2, 2013
    8
    #1 Scotter, Dec 8, 2013
    Last edited by a moderator: Sep 7, 2017
    So the other day we had a 360 towed in with a no start condition. I tried everything like punching in the secret code with the key, tried all fobs etc. I tried a few other tests and finally set about removing the alarm module/siren under the front boot area on the drivers fender well. It looked sound and the wires were secure, no corrosion etc. I finally decided to punt and got a razor and cut along the seam to take a peek inside for the infamous dead batteries. This is what I found. The batteries had leaked their guts out and eaten up the circuit board. I have never seen this before but I thought Id share this with the board as it is a common problem with batteries failing, just not like this.
    Image Unavailable, Please Login
     
  2. To remove this ad click here.

  3. Starfish

    Starfish Rookie

    Feb 28, 2012
    40
    So Cal
    Very common problem.
     
  4. tazandjan

    tazandjan Three Time F1 World Champ
    Lifetime Rossa Owner

    Jul 19, 2008
    33,717
    Clarksville, Tennessee
    Full Name:
    Terry H Phillips
    Not only common, but should have no affect on starting.
     
  5. Fatty

    Fatty Karting

    Jun 5, 2010
    236
    Australia
    #4 Fatty, Dec 9, 2013
    Last edited by a moderator: Sep 7, 2017
  6. vrsurgeon

    vrsurgeon F1 World Champ
    Silver Subscribed

    Dec 13, 2009
    13,947
    Charleston, SC
    Full Name:
    Curt
    Yup that's about right...
     
  7. To remove this ad click here.

  8. Scotter

    Scotter Rookie

    Apr 2, 2013
    8
    I forgot to mention the part about the blown fuse.

    Sent from my DROID RAZR using Tapatalk
     
  9. vrsurgeon

    vrsurgeon F1 World Champ
    Silver Subscribed

    Dec 13, 2009
    13,947
    Charleston, SC
    Full Name:
    Curt
    It is interesting that the car wouldn't start at all... unless the blown fuse quit power to the alarm system, in which case yeah the car won't start. Almost was thinking that the later models might have had version 3 of the wiring schematic and that is what led to no start versus the red light on all the time..
     
  10. Scotter

    Scotter Rookie

    Apr 2, 2013
    8
    Yeah I had no red light either...it was just dead.

    Sent from my DROID RAZR using Tapatalk
     
  11. English Rebel

    English Rebel Formula 3

    Aug 13, 2013
    2,158
    Piedmont Area of NC
    Full Name:
    Alan
    Is it best to be proactive on these batteries and install a remote rechargeable to avoid this mess? Mine was replaced over a year ago.
    Thanks
    Alan
     
  12. To remove this ad click here.

  13. tazandjan

    tazandjan Three Time F1 World Champ
    Lifetime Rossa Owner

    Jul 19, 2008
    33,717
    Clarksville, Tennessee
    Full Name:
    Terry H Phillips
    Alan- Only works if the interior of the siren and its recharge circuitry is not trashed by a leaking battery like Scot's was. Brian Crall said he replaced a few of the batteries on sirens but they always came back, so he gave up and only installs new sirens. With a GM replacement available for less than $100, not much sense in fiddling with it, even if the sound is different.

    Scotter- A blown fuse will shut her down, obviously.
     
  14. 993turbo

    993turbo Formula Junior

    Oct 4, 2006
    309
    Puerto Banus
    Full Name:
    Remi E
    Any part number / pointers for the GM part?

    :D
     
  15. cpoferrari

    cpoferrari Karting

    Jun 30, 2013
    57
    So the same issue came up with my 360. The car starts now but I was told it can fail anytime and that I should replace the module. problem is locating a new one without going for Ferrari dealer. Can anyone offer advise?
     
  16. hwyman

    hwyman Formula Junior

    Jun 25, 2015
    263
    Canada / Los Angeles
    Lol I went through the service records on my 550 and it looks like the cars had the siren replaced 4 times, I just ordered the 5th. What a great design
     
    EastMemphis likes this.
  17. one4torque

    one4torque Formula 3

    May 20, 2018
    2,291
    Houston
    Full Name:
    One4torque
    In 2 yrs of ownership I'm on my 3rd siren. Kisses and hugs to the engineer of this system.
     
    EastMemphis likes this.
  18. hwyman

    hwyman Formula Junior

    Jun 25, 2015
    263
    Canada / Los Angeles
    Wink wink someone should come up with a retrofit kit
     
  19. fotostars

    fotostars Formula Junior

    Feb 6, 2015
    284
    Bay Area
    Wow!! You probably have another issue somewhere. What replacement part are you using?
     
  20. one4torque

    one4torque Formula 3

    May 20, 2018
    2,291
    Houston
    Full Name:
    One4torque
    I did get the trev bypass finally.
     
    remfrs likes this.
  21. JaguarDriver

    JaguarDriver Karting
    Silver Subscribed

    Sep 27, 2011
    163
    Atlanta, GA
    Full Name:
    Dick Maury
    I converted to a remote rechargeable battery pack which is now easy to get to if replacement is needed. Here is a pictorial article I did: http://www.georgiajag.com/Ferrari/Alarm/alarm.html
     
  22. brogenville

    brogenville Formula 3
    Silver Subscribed

    Apr 24, 2012
    1,001
    UK
    Full Name:
    Robin
    Ah, glad to hear it. You use AV, or someone else?


    Sent from my iPhone using FerrariChat.com mobile app
     
  23. kes7u

    kes7u Formula Junior

    Oct 18, 2017
    762
    Shorewood, MN
    Full Name:
    Kevin
    Great! Yes, who did you contact for this in the USA?

    Thanks.
    Kevin
     
  24. one4torque

    one4torque Formula 3

    May 20, 2018
    2,291
    Houston
    Full Name:
    One4torque
    I used a local shop that used to work w trev.

    I did notice after the trev immob mod now my alm dash light stays on all the time when engine on.

    I tried a new siren and this did not change.

    So I presume it is an artifact of the bypass mod.
     
  25. Apollo 11

    Apollo 11 Karting

    Feb 11, 2019
    114
    San Francisco, CA
    Full Name:
    Randy
    The LED on my car stays on all the time with the car running. Is that not normal? It seems to work ok.
     
  26. one4torque

    one4torque Formula 3

    May 20, 2018
    2,291
    Houston
    Full Name:
    One4torque
    Apollo— ok maybe this is normal?? That would be nice.
     
  27. EastMemphis

    EastMemphis Formula Junior
    Silver Subscribed Owner

    May 25, 2019
    921
    Memphis, TN
    Full Name:
    John
    The LED on mine (360) stays on when the engine is running.

    This is an excerpt from the alarm manual.

    Image Unavailable, Please Login
    If I read this right, a solid LED indicates an anomaly present.
     
  28. one4torque

    one4torque Formula 3

    May 20, 2018
    2,291
    Houston
    Full Name:
    One4torque
    Thx East when i queried trev I gather it is just a side effect of the immob bypass mod.
     
    EastMemphis likes this.

Share This Page