News

308 Right front low beam headlight won't work.

Discussion in 'Technical Q&A' started by Husker, Jan 8, 2004.

  1. Husker

    Husker F1 Veteran
    Silver Subscribed

    Dec 31, 2003
    8,032
    western hemisphere
    I figured it was the bulb, so I replaced it. Wrong. Still no low beam. High beam is fine. And the left headlight, low beam and high beam are fine. Any suggestions on this one? Thanks!
     
  2. To remove this ad click here.

  3. Diablo

    Diablo Formula Junior

    Well, I would say get a test light and see if you have 12 volts at the wires.
    If you don't, there could be a possibility of a wire that has an open circuit due to the up and down motion of the headlight unit.

    Good Luck
     
  4. Nuvolari

    Nuvolari F1 Veteran
    Sponsor Owner

    Sep 3, 2002
    5,384
    Toronto / SoCal
    Full Name:
    Rob C.
    Check your fuse box. Make sure that it is not only the fuse but that power is going in and coming out of the box.
     
  5. markrolf

    markrolf Karting

    Nov 26, 2003
    116
    Kettering, UK
    Hi,

    I recently had the same problem. It turned out to be the connecter block just behind the headlight, where 3 wires go from the headlight into the car's wiring loom. Anyway, one of the connecters had come loose, simple as that!!

    Mark
     
  6. BigAl

    BigAl F1 Veteran

    Mar 17, 2002
    6,146
    TX
    Full Name:
    GSgt Hartman
    Same as Mark. My right headlight would come on then brownout. I wanted to see if it was the bulb so I switched bulbs and viola, both worked. Go figure.
     
  7. To remove this ad click here.

Share This Page