News

328: burnt connector pin starter mtr circuit

Discussion in 'Technical Q&A' started by David512, Jul 17, 2004.

  1. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    Looking for a workaround...

    An old symptom returns: initially, when the car is hot, no fuel is pumped upon engine RESTART. Eventually, it becomes a solid failure, and the car won't start at all. Apparently, after enough time and heat, the pin in the molex connector attached to the circuit board under the dash opens.

    Four years ago, Ferrari of San Francisco replaced the pin only, and the car ran fine until a very hot day two weeks ago when I stopped 15 miles from home. Through extraordinary synchronicity, a Ferrari mechanic from the Bay Area was on his way to visit relatives nearby and rescued me. He pulled down the circuit board under the dash and tweaked the connector pin a bit. I made it home. This was the first time I saw the connector itself and the actual location of the circuit board, which is more accessible than I realized. The connector has significant discoloration around the pin in question. FSF and the mechanic (formerly of FSF) say this is not uncommon at all for 328s. (Starter motor and fans are the circuits that draw the most current.)

    Instead of replacing the pin again or going deeper into the the electronics, I 've thought about splicing a short wire to the wiring harness and then soldering the other end of it directly to the circuit board so as to bypass the Molex connector altogether.

    Any more sober ideas than this out there? Maybe it would be better to replace the wire and the pin (if I can find where it goes)?

    David
     
  2. ferrarifixer

    ferrarifixer F1 Veteran
    BANNED

    Jul 22, 2003
    8,520
    Melbourne
    Full Name:
    Phil Hughes
    you should check the current draw from your fuel pump too.

    As they get old and worn (noisy?) the draw will be higher which could be the CAUSE of your problem.

    By-passing an overheated electrical connection is a recipe for trouble...
     
  3. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    Thank you ferrarifixer. Do you know a range for acceptable current draw, or do you know whether the owner's manual or more likely the shop manual has this information?

    TIA,

    David512
     
  4. ferrarifixer

    ferrarifixer F1 Veteran
    BANNED

    Jul 22, 2003
    8,520
    Melbourne
    Full Name:
    Phil Hughes
    yes, sorry forgot to say

    if constant draw is over 5 amps you have a problem. it may spike to about 8 amps when the engine is idling and using little fuel, and the fuse should be a 15A (off the top of my head, but I think that's right).

    If the draw is high, it may just be a bad earth, but likely a worn pump.

    It's just a bosch pump from any Bosch agent.
     
  5. DGS

    DGS Three Time F1 World Champ
    Rossa Subscribed

    May 27, 2003
    39,229
    MidTN
    Full Name:
    DGS
    The fuse is the safety circuit, and should never be bypassed. A connector isn't really a safety circuit. Excessive current is an indication of trouble.

    But the connectors on a 328 circuit board are inadequate for the current some of them are passing. One of the few design flaws in this car.
     
  6. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    Thank you all.

    No way would I consider bypassing the safety provided by the 15 amp fuse. (BTW, one move done by the occasional mechanic I have--not named here because he works for a private party now--was to swap with the other 15 amp fuse before he pulled down the circuit board.) Considering that the part with an impedance that starts at "okay" and later goes to inifinity, I wonder about other solutions:

    1. Run a slightly heavier wire from a new pin in the connector to its destination (not sure where that is) or ...

    Based on DGS's comment, hire someone to do the labor intensive work of putting in a better connector, which would include all the wires in that connector. I do not readily know about a correctly-sized but better connector and don't have a lot of spare time to chase one down. I might have to habd this over to the regular mechanic, Dale Dindral.

    The idea is to fix it and circumvent the design weakness in the future. For now, I am just driving it without making a stop enywhere before returning home.

    I will definitely check the amperage based on ferrarifixer's comment.

    Thanks again.
    David512
     
  7. f355spider

    f355spider F1 World Champ
    Rossa Subscribed Owner

    May 29, 2001
    17,058
    USA
    Full Name:
    Hugh G. Rection
    If you ever get an opportunity, some jpegs of this would really help me picture all this....

    Thanks,
    Dave
     
  8. DGS

    DGS Three Time F1 World Champ
    Rossa Subscribed

    May 27, 2003
    39,229
    MidTN
    Full Name:
    DGS
    Generally, the wires tend to be sized adequately. But the connector pins are all the same size, despite circuits fused between 7.5A up to 25A.
    (I find it curious that the wiring diagrams book never mentions fuse size (capacity)).

    These are spring clip type connector pins. Any weakness in the spring or corrosion on the contacts, and you can get significant heat build up.
    At 15A, even one ohm of resistance means dissapating 225 watts or 53.74 calories/sec of heat across the connector pin.
    It's not always the heaviest load pins that burn first. I had a burnt pin that disabled my instrument lights.

    But if you're having recurring issues on the same pump circuit, you may want to check for problems. If the connector shell is cracked, your new pin might have been flexing, causing it to wear. But if the shell is intact (other than being discolored), then you might have excess current. Keep in mind that the same pin (connector "W" from relay "r") drives the fuel pump, the warm-up regulator, the aux air valve, and the coil part of the "protection relay" on the ECU board. Any of them might be drawing excess current.
     
  9. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    Thanks for th highly informative posts. One last question: any suggestions on seleting two points for reading th current? Would removing the relay do it, so I would not need to unsolder something for test puposes? If I pulled the connector off, I don't know if anything else would work,

    David
     
  10. DGS

    DGS Three Time F1 World Champ
    Rossa Subscribed

    May 27, 2003
    39,229
    MidTN
    Full Name:
    DGS
    You could put the ammeter between pins 30 and 87 of the relay (r), but that would bypass the pump start circuit (relay s). Which you might want to, for testing. Keep in mind that the power to the relay is battery power (always hot), so you'll get current as soon as you connect the ammeter, even without a key in the ignition.
    You could also read the current through fuse 20. (Either connect the fuse in series, or make sure your ammeter is fused, or both.)
     
  11. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    Using the fuse SOUNDS like the simplest. You post brings up another subject, which may or may not have been the pronlem: the pump start circuit. Since the failures always happened when I tried to restart the car after being hot, I wonder if that could be it? After the mechanic who stopped by started the car, when he raised and lowred the circuit, the engine cut out.

    I reread the bill from Ferrari of San Francisco. It states they replaced the "wiring harness connector," but I am skeptical because they charged only $165 for would seem like a labor-intensive job. I recall the mechanic telling me over the phone that they "repaired the pin."
     
  12. DGS

    DGS Three Time F1 World Champ
    Rossa Subscribed

    May 27, 2003
    39,229
    MidTN
    Full Name:
    DGS
    The start circuit is fairly easy to check. With the engine off, turn the ignition to "on" (not start). You shouldn't hear the fuel pump (yet). If you depress the AFM meter plate, then you'll hear the fuel pump. Don't run it this way too long, as the CIS is dumping fuel into the intakes while the pump is running, and you'll "flood" the car.

    The "pump start" circuit is a little odd, but it makes sense in operation. When you turn the key "on" the ignition relay (u) activates, sending power to the coil and normal position of the start relay (s). The coil of relay (s) is grounded through the AFM safety switch -- at ground when the plate is at rest (no airflow). With relay (s) active, the key start position is fed (through fuse 9 ) through relay (s) to the coil of the fuel pump relay (r). With airflow, the coil of (s) is interrupted, and ignition power (from u) drives the fuel pump relay (r).

    Clear? ;) In operation, it means that the fuel pump doesn't run unless you either (a) are running the starter motor or (b) have airflow. So if the car stalls, relay (s) activates, and the fuel pump cuts off (until you restart).

    If your AFM switch shorts to ground when hot, it would cause the car to stall as it cuts off the fuel pump. If fuse 9 opens when the circuit board warms up, then you wouldn't be able to start the car from the key switch, but pushing the AFM plate down would still start the fuel pump. If your thermo-time switch isn't cutting off the cold-start injector, you might be overheating F9.

    "Repaired the pin" might mean that they re-bent it to hold, or it might mean that they replaced the pin. They might have replaced the shell, but that should appear on the parts portion of the invoice.
     
  13. Verell

    Verell F1 Veteran
    Consultant Owner

    May 5, 2001
    6,992
    Groton, MA
    Full Name:
    Verell Boaen
    I hope they replaced the pin. As any attempt at straightening/tightening one is futile.

    I believe the connector is either an A-MP or Molex.
    In either case, the pins are essentially identical. Back in the mid-'70s DEC was usng them to power PDP-11 backplanes & was having pin burnout failures after about 24-36 months. I ended up being the engineer assigned to solve the the problem. Turns out that while the pins are rated for 25A when new, over time the tin plating oxidizes. Under vibration,the contact area shifts slightly, thus the oxide slowly works its way into the contact area, resistance increases, heat increases, oxidation rate increases.... - A vicious circle.
    Under 10-15A loads, the connectors wouled last a lot longer before the runaway process would start, but the end result would be the same.

    The connectors were very reliable at 4-6A, but above that it was a matter of time & environment.

    A PM every 12-18months consisting of disconnecting & reconnecting the connectors would wipe all of the oxide out of the contact area. With the PM, the connector life at 10-15A became very long.

    Any attempt to manually increase contact pressure would result in either the inner pin, or the mating sleeve being deformed out of round & significantly decreasing the contact area. It would also result in uneven contact pressure. As a result, the runaway would begin quicker & failure would occur in a few weeks/months.

    We actually redesigned some of the backplanes to double the number of pins, thus getting the current/pin down.
     
  14. DGS

    DGS Three Time F1 World Champ
    Rossa Subscribed

    May 27, 2003
    39,229
    MidTN
    Full Name:
    DGS
    Well, if they only re-bent it, it might explain why he's having trouble with it again.

    These aren't round pins. The circuit board pins are flat (rectangular) with the wire harness mating connector using spring loaded pins that contact the flat sides.

    Interesting about the PM, but I'm not sure R&R-ing the circuit board annually would be practical on the 3x8, given the additional flex wear on the cabling that such process would incur in tight quarters.
     
  15. f355spider

    f355spider F1 World Champ
    Rossa Subscribed Owner

    May 29, 2001
    17,058
    USA
    Full Name:
    Hugh G. Rection
    Sounds like a job for Stabilant 22! ;)
     
  16. David512

    David512 Formula 3

    Dec 15, 2003
    1,647
    Northern California
    What's that?
     
  17. f355spider

    f355spider F1 World Champ
    Rossa Subscribed Owner

    May 29, 2001
    17,058
    USA
    Full Name:
    Hugh G. Rection
    Electrical contact enhancer: http://www.stabilant.com/ in spite of their lame website, the stuff really does work, and is available at Napa auto parts stores, though they will probably have to "special order" it for you. It is very expensive. One of the cheaper sources is VW dealers, as Volkswagen endorses and uses it (though they will likely have to special order it too). I guess the stuff is so expensive, no one wants to carry it on the shelf. ;) I small vial from VW runs around $50.

    I have heard several testimonials on this list from folks that have used it to correct various electrical gremlins on 348's and TR's. Generally related to the various electrical connectors in the engine compartment which can create drivability problems and "check engine" lights. My friend's 348 spider had some issues that were corrected with this stuff.

    Dave
     

Share This Page