News

348 348 won't crank

Discussion in '348/355' started by jebones, Jun 15, 2020.

  1. jebones

    jebones Karting

    May 13, 2015
    53
    NEOhio
    90 TS stored all winter on battery tender. Started 1 month ago first crank bringing out of storage. Parked and not driven (due to weather) not on tender. Now turn the key, all lights and blower are working but turn the key to start and nothing... Lights don't dim, and no click at the starter. In the past when it was hot I would occasionally get a click when trying to start but then would start fine second try. I purchased a relay for the starter but haven't installed it yet. Just looking for advise on where to start looking. Ignition switch? Starter solenoid?
     
  2. To remove this ad click here.

  3. flash32

    flash32 Formula 3

    Aug 22, 2008
    2,203
    Central NJ
    Full Name:
    Dominick
    I would check battery first .. try testing it , charging it etc

    Then move from there

    Sent from my moto g(7) using Tapatalk
     
  4. bjwhite

    bjwhite F1 Rookie

    Mar 17, 2006
    3,988
    Seattle, WA
    Full Name:
    Brian White
    My bet is starter solenoid or the connections there.
     
  5. carlo348

    carlo348 Rookie

    Jan 20, 2014
    33
    Charge or swap out battery first, then check starter solonoid it it doesnt turn.
    My battery went last year. Same problem, with all lights on. Its surprising how much more juice in the battery is required to get even a click out of the starter.

    Sent from my SM-G960F using Tapatalk
     
    flash32 likes this.
  6. Qavion

    Qavion F1 Rookie
    Silver Subscribed

    Feb 20, 2015
    4,874
    Sydney
    Full Name:
    Ian Riddell
    Do you have an aftermarket immobiliser? Apart from batteries and starter solenoids, these cause problems from time to time.
     
  7. To remove this ad click here.

  8. jebones

    jebones Karting

    May 13, 2015
    53
    NEOhio
    Thanks for the feed back. I won’t be able to address until next week due to work and travel. The car does have an alarm that was installed when the car was new. A Clifford alarm system. It would blare the horn when I would turn on the battery at the main cut off so I disabled it. It’s a complex system using 90’s tech so it might be acting up.
    I’ll first check the battery and post again if still no crank.



    Sent from my iPad using FerrariChat.com mobile app
     
    Qavion likes this.
  9. Meister

    Meister F1 Veteran
    Silver Subscribed

    Apr 27, 2001
    5,383
    Duluth, MN
    Full Name:
    The Meister
    battery. I had two cars come out of storage this spring, tender showed "green" battery good...nothing. Install new battery...presto.
     
  10. jebones

    jebones Karting

    May 13, 2015
    53
    NEOhio
    Well I finally got a chance to address the no crank issue. Good news is that it cranked first try and started. The bad news is that it cranked and started first try. Now I have no idea why it happened or will happen again. I did not put it back on the tender or charge the battery so doubt it was a weak battery. I’ll plan on several point A to point A trips to see how she behaves. I’ll install the starter relay in the next week. Time is limited and I’m in the final assembly stages of a Lancia Flaminia Touring convertible and installing a clutch with my son on his Alfa GTV6. I’ll repost if issues arise.

    Thanks for the tips
     
    Qavion likes this.
  11. Qavion

    Qavion F1 Rookie
    Silver Subscribed

    Feb 20, 2015
    4,874
    Sydney
    Full Name:
    Ian Riddell
    Thanks for the update. Good luck with the starter relay.
     
  12. To remove this ad click here.

Share This Page