News

355-suspension warning light

Discussion in '348/355' started by Tonksy, Jun 14, 2004.

  1. Tonksy

    Tonksy Rookie

    Jun 11, 2004
    4
    Rickmansworth, UK
    Full Name:
    Mark
    I have recently taken delivery of my 355 after a rather lengthy spell at the local garage with a miss-fire issue. Since it has come back I have driven around 50 miles and the suspension warning light has come on. I’ve have checked as best I can to see if ride height has dropped etc, but all seems ok. Is there anything else I can check?
     
  2. To remove this ad click here.

  3. RF128706

    RF128706 Formula Junior

    Apr 8, 2004
    280
    Tonsky, I'm no expert on this subject, but I have learnt a couple of things:

    1. If I jack my car up/let it down (even with ignition off) it will light the suspension light. Sometimes it will recover by itself & sometimes I have to disconnect the battery for it to reset. Try disconnecting the battery for 5 mins.

    2. Everytime you key-on the 'brain' cycles all the actuators on each damper for 1 full cycle. If any of the acuators malfunctions during initialisation it will light the warning lamp. If the light is on from key-on you can check each actuator in turn by unplugging it from its damper, turning on the ignition and watching it complete a full cycle.

    3. If it's none of the above you need to get to a F. Dealer to get the error code read by the SD1 machine.

    If you disconnect the battery, remember to run the car for 10 mins at idle for it to relearn its idle calibration parameters.

    Good luck,

    Rob.
     
  4. pchop

    pchop Formula 3
    Rossa Subscribed

    Jun 12, 2002
    2,379
    Usually NY often elsewhere.
    Full Name:
    John
    I had mine go on for about 15 miles. Then it just went off by itself. Also try to change the suspension swith to Comfort from Sport or vice versa. If the problem persist after 50 miles or so, have it check out at the dealership.
     
  5. mondial86

    mondial86 Formula Junior

    Nov 1, 2003
    298
    MA
    Full Name:
    David Holmes
    Is the speedo working ?My light came on and I also saw that the spedo was out ,there is a pluse sensour that feeds info to the susspen.ecu and to the speedo ,if the sensor fails than the light comes on ,I replaced the pluse sensor and all is ok now
    DAVID
     
  6. zjpj

    zjpj F1 Veteran

    Nov 4, 2003
    5,938
    USA
    We used to have a 1995 355 spider and had the light go on. It went to the shop. It turned out we had leaky shocks and they had to replace them - $1,800 (this was many years ago too)
     
  7. To remove this ad click here.

  8. Tonksy

    Tonksy Rookie

    Jun 11, 2004
    4
    Rickmansworth, UK
    Full Name:
    Mark
    I'll disconnect the battery and see what happens, have already tried the actuators and also tried reseating a couple of connections. If all fails I'll take it to a dealer.

    Thanks for all your help......
     
  9. stan996turbo

    stan996turbo Formula Junior

    Jun 11, 2004
    563
    Philadelphia
    Full Name:
    Stan
    I had the same problem with my 97 355, the shock light would go on and off. The problem was resolved by removing the red cap on top of the shock tower and tightening the bolt.
     

Share This Page