News

360 Challenge "limp Mode"

Discussion in 'Challenge/GT Cars' started by PFez81, May 16, 2020.

  1. PFez81

    PFez81 Rookie

    Jun 10, 2019
    14
    Hi Guys,

    So I'm at my wits end with our Race car (360 Challenge). I share the car with another person who drives it much less "spirited" than myself. Whenever I hop into the car I seem to trigger the ECU to go into some sort of "Limp mode". It usually happens after going hard on the brakes and gearing down for a tight low speed corner. I have hear that changing down too fast can throw the TCU out but I am making a conscious effort to not change down too fast\ and its still happening.

    Does anyone have any experience with any kind of issue like this? Could there be some glitch in the ECu or should I just rip the factory ECU's out and rewire for a Motec or something so that I can customise the speed which i can brake and change gears or am I barking up the wrong tree?

    Appreciate any help that can be offered. thanks.
     
  2. greg512tr

    greg512tr Formula Junior
    Rossa Subscribed Owner

    Feb 19, 2002
    963
    Dallas TX
    Full Name:
    Greg B
    I had this happen to me once and I cut power to it via red key, let it sit for 15 minutes and upon restarting everything was fine. The “limp home” lap around Watkins Glen to get back to the pits was no fun. It has never done it again.



    Sent from my iPhone using FerrariChat
     
  3. PFez81

    PFez81 Rookie

    Jun 10, 2019
    14
    Thanks Greg, yes that’s what I have to do, switch red key off and wait and then the fault clears. The problem is that it happens to me approx 3-4 times every session. If it happened once in every 2-3 track days it wouldn’t bother me so
    Much.
     
  4. PFez81

    PFez81 Rookie

    Jun 10, 2019
    14
    Okay, so speaking with my mechanic Has led me to believe there may be a lose terminal or marginal grounded cable on the car somewhere that is causing this intermittent issue. We are going to unplug all the terminals and blow them out and spray with contact spray to see if we can sort this issue. Mechanic did get excited at the prospect of having a motech put in there!
     

Share This Page