News

430 gauge cluster dead & F1 issues.. simple fix or not?

Discussion in '360/430' started by MD326, Aug 3, 2009.

  1. MD326

    MD326 Karting

    May 6, 2007
    191
    MD & FL
    Full Name:
    WJP
    First off, I would like to thank everyone in advance with any help rendered.. :) I tried to search but of course I seem to be search "challenged".

    Now for the problem(s).. :(

    The gauge cluster has gone dead.. no lights and no tach movement.

    Also, the F1 trans is will not shift past 2nd gear. This may be a result of the gauge cluster not working - some type of limp mode.


    This type of malfunction has me guessing a fuse problem. I have a couple high priority fuses that could be the issue but thought I would call on some of you experts for advice before I start tearing my 430 up and do any further damage.





    Will P.
     
  2. fc2

    fc2 F1 Veteran
    Owner

    Nov 2, 2006
    5,136
    Silicon Valley Ca.
    Full Name:
    Frank C.
    Will... were you doing anything abnormal (jump starting the car, hard wiring in a radar detector etc) before this happened?
    I know the 360 gauge cluster was pretty sensitive to voltage spikes, but I haven't heard of 430's having this same "feature".
     
  3. SonomaRik

    SonomaRik F1 Veteran

    Dec 15, 2006
    6,691
    Sonoma, CA
    what I was thinking.....and yes, have heard the 430's having same problem.
     
  4. tazandjan

    tazandjan Three Time F1 World Champ
    Owner Lifetime Rossa

    Jul 19, 2008
    30,942
    Albuquerque, NM
    Full Name:
    Terry H Phillips
    Will- The experts on digital instrument clusters are FAI in California. They rebuilt my 575 SA cluster for a reasonable price. At least Rod may be able to tell you what the problem is from the symptoms. Not sure about the no shifting past second part.

    Taz
    Terry Phillips

    Franchorchamps of America, Inc.
    935 Sunset Dr Suite A
    Costa Mesa, CA 92627
    (949) 631-6373

    Rod Drew
    t28flyer@yahoo.com

    Will White
    http://www.ferrarioc.com/
     
  5. Ingpr

    Ingpr F1 Rookie

    Jun 30, 2009
    2,574
    PR
    Full Name:
    David
    Hello,
    This exactly what’s happening to my Scud.
    Did you solved this???
    Thanks!
     
  6. Ingpr

    Ingpr F1 Rookie

    Jun 30, 2009
    2,574
    PR
    Full Name:
    David
    Thanks Eric!
    Any ideas that could be happening to the cluster? I changed all the related fuses and check the relays.
     
  7. eric355

    eric355 Formula Junior
    Silver Subscribed

    Nov 30, 2005
    881
    Toulouse (France)
    Full Name:
    Eric DECOUX
    Don't know, could be as simple as a voltage regulator which has failed.
    First thing I would do is to check if battery voltage (+30) and switched power (+15) are present on the cluster connector.
     
  8. Ingpr

    Ingpr F1 Rookie

    Jun 30, 2009
    2,574
    PR
    Full Name:
    David
    Thanks man.
    When you said +30 you mean “milliamps “?
     
  9. eric355

    eric355 Formula Junior
    Silver Subscribed

    Nov 30, 2005
    881
    Toulouse (France)
    Full Name:
    Eric DECOUX
    No,
    +30 is the nomalized name for wires and pin of connector directly connected to the battery (uninterrupted +12V)
    +15 is the nomalized name for wires and pin of connector connected to the battery through ignition switch (switched +12V)
     
  10. eric355

    eric355 Formula Junior
    Silver Subscribed

    Nov 30, 2005
    881
    Toulouse (France)
    Full Name:
    Eric DECOUX
  11. Ingpr

    Ingpr F1 Rookie

    Jun 30, 2009
    2,574
    PR
    Full Name:
    David
    Thanks man!
    Really appreciate it.
     
  12. Ingpr

    Ingpr F1 Rookie

    Jun 30, 2009
    2,574
    PR
    Full Name:
    David
    I disconnect the battery all night to see if the problem was related to the diodes. This morning a re connect the battery, lock and un lock the car and the cluster looks fine. I also open the luggage lid and it works.
    But once I switch the car to on without turning the car on the cluster went dead again and also the open lid and wipers ‍♂️
     

Share This Page