News

456 GT : Instrument lights not working - any ideas?

Discussion in 'Technical Q&A' started by joelk, Nov 1, 2003.

  1. joelk

    joelk Rookie

    Nov 1, 2003
    35
    Hi there,

    I have a 1994 456 GT. The lights of my speedo, rev counter, oil temp and other dials aren't lighting up anymore. I've checked the fuse in the passenger side footwell, and they seem fine.

    Anybody got any ideas / suggestions what else it could be ? (or how do I check if it's just the bulb).

    Many thanks,

    Joel
     
  2. Teenferrarifan

    Teenferrarifan F1 Rookie

    Feb 21, 2003
    2,989
    Media, PA
    Full Name:
    Erik
    This happened to my dad on his 355. I am sure it is the same on the 456 at least I hope so. On the tach there is a black knob it looks like a trip reset knob. Spin it to the right and it will adjust the instrament panel lights all the ones you said are out will be adjusted with this. If it is all the way turned the lights will be off just turn it and they should come back on.
    Erik
     
  3. donv

    donv F1 World Champ
    Rossa Subscribed Owner

    Jan 5, 2002
    18,451
    Portland, Oregon
    Full Name:
    Don
    I assume you know about the dimmer on the lower left of the steering wheel, next to the hood release, right?

    (I didn't figure it out for a few days myself!)
     
  4. joelk

    joelk Rookie

    Nov 1, 2003
    35
    That's great guys. Many thanks. It was as simple as that - just turned the dial. Doh! (feel a bit silly now, but live and learn eh?)

    Cheers!
     

Share This Page