News

612 heated seats issue..

Discussion in '612/599' started by MRY, Sep 25, 2017.

  1. MRY

    MRY Karting

    May 14, 2015
    220
    Monterey Peninsula
    Hi all,

    Sometimes the heated seats in my 612 will come on and go off all by itself.

    Has anyone experienced this situation?

    Could it be the relay? (I hear it clicking away when the seat comes on and off)

    Or the switch?

    Thoughts? Insight?

    Thanks


    Sent from my iPhone using Tapatalk
     
  2. Shiva_Austria

    Shiva_Austria Rookie

    Oct 7, 2013
    49
    Austria
    Hi, I have the same problem with my 612 but no solution.


    Gesendet von iPhone mit Tapatalk
     
  3. TheCook

    TheCook Formula Junior

    Oct 16, 2015
    279
    Buckinghamshire
    Full Name:
    Ian
    Try looking under it and checking all electrical connection boxes are secure. It may not be it but this sorted the issue I had with the airbag warning coming on intermittently. Needed to squeeze them all closed and been good since then.


    Sent from my iPhone using Tapatalk
     
  4. MRY

    MRY Karting

    May 14, 2015
    220
    Monterey Peninsula
    Ok, I'll try it and see what happens!

    Thanks


    Sent from my iPhone using Tapatalk
     
  5. Canuck550

    Canuck550 Formula Junior
    Silver Subscribed

    Sep 8, 2015
    419
    Incognito
    Full Name:
    RJA
    apparently you need to get part of the gauge cluster rebuilt from what I was told, google it....This is a common problem for 612
     
  6. Motob

    Motob Formula 3
    Professional Ferrari Technician

    Nov 11, 2003
    2,143
    Berkeley, CA
    Full Name:
    Brian Brown
    Sounds like a bad switch. You need to have someone with a diagnostic computer check the operation of the switch to see if the input to the ecu and feedback from the seat heater is working as it should.
     
  7. swiss612

    swiss612 Karting

    May 10, 2016
    217
    Zurich
    Full Name:
    Michel
    I have this sometimes also.... my concern is that I have no heated seats : -)
     
    Makuono likes this.
  8. StickBreitling

    StickBreitling Formula Junior

    Oct 12, 2012
    342
    Had that happen to mine on both driver and passenger seats. Didn't mind during the winter, but summer was bad. The dealership quoted 3000 GBP per seat for a replacement heating unit!
     
  9. Wdemuynck@hotmail.com

    Mar 24, 2015
    35
    Izegem Belgium
    Full Name:
    Willem Demuynck
    had the same here, i was wondering already if i had a hangover or my seats were heating on there own :)
    Hasn't happened that offten though, but from time to time
     
  10. Alcav5

    Alcav5 Formula 3
    Silver Subscribed Rossa Subscribed

    Jul 28, 2012
    2,142
    Scarsdale, NY
    Full Name:
    Al
    Hmm.
    I have seen my dash screen light up and show the heated seat icon (driver & or passenger) even though I had not turned them on. I just thought a computer glitch, it also occurred in my California's, I dislike the rotary switch bc I can never remember which way is on or off. I never really noticed if the seats were in fact getting warm or not nor did I hear any clicking sounds. I'm really not a fan of having it investigated, from the previous posts it sounds like 3 different shops will say 3 different causes.
     
  11. southnc

    southnc Formula 3
    Silver Subscribed

    Dec 25, 2013
    1,748
    Charlotte, NC
    Full Name:
    Adam
    Have this same problem as well.

    About 50% of the time, I'll get the heated seat warning on the display.

    Still not sure what it is.
     
  12. JohnBradleyDaniels

    Rossa Subscribed

    Oct 16, 2011
    136
    Spartanburg SC
    Add me to the list. I have passenger heated seat indicator come on the dash but I have no heated seat option. Also my RPM's act like a Rolex sometimes "ticking" up..... but not often enough. I suspect the cluster is the issue as my California indicates passenger heated seat on but I do have heated seats in it. Ferrari did say the cluster was bad in it and the rpms where off. I am thinking of sending the California to a guy in California that rebuilds it for just under $600, anyone ever used this service? I'm not about to go thru the dealership on possibly two clusters...Cheers!
     
  13. Canuck550

    Canuck550 Formula Junior
    Silver Subscribed

    Sep 8, 2015
    419
    Incognito
    Full Name:
    RJA
    Guys...as mentioned prior apparently you need to get part of the gauge cluster rebuilt from what I was told, google it....This is a common problem for 612...
    Google is your friend, there are a few ref on the web and where to get rebuilt
    I looked at several cars, approx 2 years ago, with this issue and eventually settled on a 550 instead
     
  14. JohnBradleyDaniels

    Rossa Subscribed

    Oct 16, 2011
    136
    Spartanburg SC
    Had an '01 550 6 years ago. Loved it!
     
  15. Craddock

    Craddock Rookie

    Nov 12, 2016
    21
    I had this in my 612 and it hasn't got heated seats... I occurred to me that it was most common when the kids were in the back as they had a habit of lifting up their feet underneath the seats. The cluster of connectors that seems to control most of the seat stuff is right at the bottom rear of the seat so their occasional kicking was sufficient to lead the car to think the heated seats were on (despite not having heaters). All i did was push the connectors together tightly and fix them out of the way with some cable ties and the problem has gone away completely.

    Now... if i could stop the car thinking its parking sensors are broken so simply that'd be wonderful!
     
  16. swiss612

    swiss612 Karting

    May 10, 2016
    217
    Zurich
    Full Name:
    Michel
    Thanks for the tip, I will try to replicate the issue and correct it
     
  17. swiss612

    swiss612 Karting

    May 10, 2016
    217
    Zurich
    Full Name:
    Michel
    I tried to touch the wires under the seat, but did not get any message
    Would you know which specific one it is ?
     
  18. brogenville

    brogenville Karting

    Apr 24, 2012
    223
    UK
    Full Name:
    Robin
    Old thread revival day...

    I now have a scan tool that can talk to the seat modules, and have discovered that I have some error codes to go on to help diagnose the phantom heated seats.

    fault codes are:
    B1027 - Heating Feedback error
    B1017 - Seat hearing relay or cable

    Both were stored faults rather than active, but it does give something to go on. The SD3 diagnostic help suggests that the fault is in the seat heating relay. As there isn’t an external relay for the seat heaters, I assume the relays are in the ecus, which are under each seat.

    Plan next is to take the passenger seat ecu out and see if there is a relay in there I can swap out. Will report back.

    Anyone else fixed this issue by changing out the seat ecu?
     
  19. brogenville

    brogenville Karting

    Apr 24, 2012
    223
    UK
    Full Name:
    Robin
  20. brogenville

    brogenville Karting

    Apr 24, 2012
    223
    UK
    Full Name:
    Robin
    So this is the relay responsible for the seat heating element. New one ordered online for £7.75. Will solder it in and see if that helps!
    Image Unavailable, Please Login
     

    Attached Files:

    599_GTO and Anthony James like this.
  21. Nospinzone

    Nospinzone F1 Rookie

    Jul 1, 2013
    4,648
    Weston, MA
    Full Name:
    Paul
    Fingers crossed, and thanks for that info!
     
    MRY and Anthony James like this.
  22. m5shiv

    m5shiv Formula Junior

    Feb 25, 2013
    656
    SF Bay Area
    Full Name:
    Shiv
    Same issue here. Jason in his epic 612 revival thread stated that it was the switches.
     
  23. montegoblue

    montegoblue Formula Junior

    Aug 7, 2009
    357
    Chattanooga, TN
    Hope you fix it ... owned my 612 for 6 years and never could sort it out. Asked the dealership, it would get better for a while and then right back on at the least expected time, often of course when it was 100 degrees outside! I just gave up eventually and attributed to one of the big girl´s quirks.
     
  24. brogenville

    brogenville Karting

    Apr 24, 2012
    223
    UK
    Full Name:
    Robin
    I don’t think so. I took the switches apart, cleaned and tested everything, and whilst I thought it was helping for a bit, the problem sadly returned.

    The error codes seem to be the car saying “hey, the heated seat came on when I wasn’t expecting it to” (incorrect feedback). If it was the switch at fault, then you would expect the car to interpret that as a genuine demand for seat heating, and not trigger a fault.


    Sent from my iPhone using FerrariChat.com mobile app
     
  25. m5shiv

    m5shiv Formula Junior

    Feb 25, 2013
    656
    SF Bay Area
    Full Name:
    Shiv
    Can't see that attachment
     

Share This Page