News

bucking at 3500 rpm all gears

Discussion in 'Boxers/TR/M' started by B512M, May 27, 2010.

  1. B512M

    B512M Karting

    Mar 26, 2008
    111
    flood city
    Full Name:
    Christian
    Not sure what happen, it was running fine previously except my fuel level sender unit is always on even when the tank is still half full. Yesterday, I washed the car and when I take it out to dry it, it was bucking at 3500 rpm in all gears, (it feels like you hit the rev limiter). I didn't want to push my luck, so I went home asap. what could be the likely problem ?
     
  2. To remove this ad click here.

  3. Hawaii

    Hawaii Formula Junior

    Jan 28, 2007
    847
    Maui
    Full Name:
    Emery
    Guessing wet electrics. Try it again after it dries out.
     
  4. Norm512TR

    Norm512TR Formula Junior

    Nov 10, 2001
    892
    Colorado Springs, Colorado
    Full Name:
    Norm
    I have a similar issue with my car. As it starts to warm up- not cold and not yet fully up to temp- it will buck hard, it feels just like the car is hitting the rev limiter. It's been in the shop a couple of times for this and no one has ever been able to find a problem. In my case it has nothing to do with washing the car.

    Let's see what the experts have to say....
     
  5. finnerty

    finnerty F1 World Champ

    May 18, 2004
    10,341
    #4 finnerty, May 28, 2010
    Last edited: May 28, 2010
    (I ain't no expert, but...)

    CHRISTIAN ---

    I agree with Emery --- first, let the engine fully dry out (might take a couple of days), then, if you still have the problem, I would ask the following:

    Does the problem change with engine load? Meaning that although you are at the same RPM, does it "buck" when you are accelerating to 3500, cruising at 3500, lifting off throttle down to 3500 ---- or all of the above?

    This could help differentiate whether the problem is fuel related or ignition related.
     
  6. finnerty

    finnerty F1 World Champ

    May 18, 2004
    10,341
    #5 finnerty, May 28, 2010
    Last edited: May 28, 2010
    (I still ain't no expert, but...)

    NORM ---

    Your problem sounds fuel delivery or vacuum (leak) related. Have any of the shops done a COMPLETE fuel pressure check of the system?

    Also, have they checked the vacuum cut-off / limiting device?
     
  7. To remove this ad click here.

  8. B512M

    B512M Karting

    Mar 26, 2008
    111
    flood city
    Full Name:
    Christian
    David, it will accelerate like its normal below 3500, then it starts bucking, so i lift off. I can't cruise over 3500 rpm, it would not go higher than 3500rpm. and no check engine lights are on.
     
  9. B512M

    B512M Karting

    Mar 26, 2008
    111
    flood city
    Full Name:
    Christian
    Left the car in the garage for a week. Took it out again last night, and she ran perfectly. Like you guys said, wet electrics. Remember guys, careful not to spill any water into that engine bay. I am used to washing my 'rice burners', forgot the special care needed to wash the TR.
     
  10. jlonmark

    jlonmark F1 Rookie

    Mar 29, 2005
    2,962
    Beverly Hills, CA
    Full Name:
    Jay
    Sounds like it can be a few problems:

    1) Water in the electrical system
    2) Vacuum line (maybe came loose with the wash
    3) When did you change the spark plugs last?
     

Share This Page