News

Engine symbol at start?

Discussion in '360/430' started by cyclisto, May 23, 2009.

  1. cyclisto

    cyclisto Formula Junior

    Nov 21, 2008
    355
    Utopia
    Full Name:
    Sy Kleesteau
    Sometimes the engine symbol will light up when I start the 430, other times it won't. Sometimes it stays on for roughly a minute, then it turns off. I guess I shouldn't worry about it unless it stays on, but why does it sometimes light up at all? Another Ferrari gremlin rearing it's ugly head? Should I take it in to the dealer?
     
  2. To remove this ad click here.

  3. TheMayor

    TheMayor Eight Time F1 World Champ
    Rossa Subscribed

    Feb 11, 2008
    83,533
    Vegas baby
    My 08 430 always stumbles at start up and the engine light is on. Then, after about 5 seconds or so, the engine smooths out and the light goes off.

    I've had a problem with the engine light staying on permanently and the dealer has sent the ECU's back to FNA 2 times for reprogramming. I haven't had any problems with the light staying on since the last reprogramming but the stumble remains as it has since I received it new. I have to assume that this is the way it's supposed to start and run as the two banks synchronize. Honestly, I don't worry about it as long as the light doesn't stay on permanently.

    As to not coming on at all, I've never seen ANY "check engine" light in any car not light up when started. That does sound a bit weird. If that's happening, I would have it checked out. They should be able to read the codes pretty easily and figure out what's up.

    And, a minute of stumbling sounds like quite a bit. A few seconds I would say sounds normal. A minute of stumbling sounds extreme, even in severe weather.
     
  4. RSQP

    RSQP F1 World Champ
    Rossa Subscribed

    Apr 25, 2005
    11,496
    California
    Full Name:
    Beaker
    When firing up the Scuderia, the CEL comes on and the engine almost sounds like it's going to stall, but then picks up as if nothing happened. The techs said not to worry about it. Sounds like it might be a feature.

    The fact that these mostly hand-built cars perform the way they do, not to mention the fact that they run at all, is pretty remarkable.
     
  5. fc2

    fc2 F1 Veteran
    Owner

    Nov 2, 2006
    5,136
    Silicon Valley Ca.
    Full Name:
    Frank C.
    Every time I start my '07 F430, the CEL comes on and stays on for roughly 15 seconds, but of course it feels like it's a lot longer because I'm staring at it wishing it away.
     
  6. cyclisto

    cyclisto Formula Junior

    Nov 21, 2008
    355
    Utopia
    Full Name:
    Sy Kleesteau
    that's what i thought. i guess the 15 secs feel like "a minute." but if it doesn't come on at all, should i be worried?

    thx guys!


     
  7. To remove this ad click here.

  8. Rifledriver

    Rifledriver Two Time F1 World Champ

    Apr 29, 2004
    27,157
    Austin TX
    Full Name:
    Brian Crall
    The light is supposed to come on as a test every time the motor is started. It is run by a timer and should go off at the same interval every start.
     
  9. 430-Scuderia

    430-Scuderia Karting

    Oct 20, 2008
    57
    Netherlands
    Ok, my Scuderia also does that sometimes. Cold-start. The car shakes, oil pressure is low and when you hit the accelerator to get out of the garage it almost stalls. I always turn it off and start it again. When you do that, second time, no "problem" whatsoever.
     
  10. $$$=SPEED

    $$$=SPEED F1 Veteran

    Aug 18, 2004
    5,289
    Portland, Or. USA
    Full Name:
    Depends who's asking
    So funny I do the same thing. "come on go off...come on go off" :)
     
  11. Solobagpiper

    Solobagpiper Karting

    May 6, 2009
    114
    Piedmont, California
    Full Name:
    Mark Frost
    check to make sure that your gas cap is tightened all the way down.
     
  12. To remove this ad click here.

  13. JMC08

    JMC08 Rookie

    Oct 30, 2014
    18
    I am having similar issues. The car always stumbles at start up, and acts like it will stall. The CEL light usually stays on for 12-17 seconds. According to the owner's manual, it is only suppose to stay on for 4 seconds after startup. Today, I drove it to Lowes. I turned off the car long enough for my wife to take the key and turn the passenger airbag back on, then I turned started the car back up. After startup (from the engine being off for maybe 30 seconds) the car idled extremely rough for a good 30-45 seconds before smoothing out. Ten minutes later after my wife came back out from the store we pulled away and left. Going through the parking lot (10 mph) we came to a stop sign. The car then stalled on us. I put the car in neutral and pressed the starter button, the car fired right up as if nothing had happened. Any ideas what may be going on? Thank you in advance.
     
  14. Red 27

    Red 27 Formula Junior
    Rossa Subscribed

    Feb 2, 2008
    966
    San Diego, Ca
    Full Name:
    Dave
    Are you waiting for the "OK" to appear before pushing the start button?
    My 07 430 check engine light stays on for about 17 seconds before going off after startup.
     
  15. Perkins

    Perkins Formula Junior

    Dec 22, 2013
    701
    Sacramento
    Full Name:
    Rick
    Mine does the same thing. I'd guess about 10-15 seconds at each start.
     
  16. big_guy

    big_guy F1 Rookie

    Sep 9, 2007
    3,190
    Ontario, Canada
    Same with mine.
     
  17. Rbwiii

    Rbwiii Formula Junior
    Silver Subscribed

    Aug 9, 2014
    597
    Cali
    Full Name:
    BW
    My 07 does the same also
     
  18. Joegnsx

    Joegnsx Formula Junior
    Owner

    Dec 1, 2012
    928
    Valrico, FL & Franklin, NC
    Full Name:
    Joe Gliksman
    My 05 also takes about 15 seconds for the CEL to go off--every time I'm pretty sure.
     
  19. scudF1

    scudF1 F1 Rookie

    Jan 21, 2012
    2,655
    Long Island, NY
    Full Name:
    Billy
    I timed mine before. It is not consistent all the time. Sometimes it takes 8 and sometimes 10 min. I noticed that the first time you start the car and its cold, it takes longer.
     
  20. F360-1386

    F360-1386 Formula 3

    Oct 8, 2006
    1,638
    Markham, ON, Canada
    Full Name:
    51216M
    Normal , nothing to worry! Mine was on since day one for few years around 10 sec , it was gone.
     
  21. JMC08

    JMC08 Rookie

    Oct 30, 2014
    18
    Thanks for all the replies. The Scuderia is our first Ferrari, a lot to learn. I did wait until the dash gave me the ok before pressing the starter button today. The car did not stumble upon cold start. The only thing I still question though is the rough idle after restarting the engine (warm) 30 seconds after turning it off...and then the stall ten minutes later. Otherwise, the car is amazing and loads of fun. Very mechanical, and just takes a bit of time to adjust to.
     
  22. Red 27

    Red 27 Formula Junior
    Rossa Subscribed

    Feb 2, 2008
    966
    San Diego, Ca
    Full Name:
    Dave
    You need to wait for the "OK" every time you start the car.
     
  23. Xcheckme

    Xcheckme Formula 3

    May 10, 2011
    1,682
    Tampa Bay
    Full Name:
    Lukas
    This - but even then it is normal for the check engine light to stay illuminated for up to 15 seconds.
     

Share This Page