News

F430 Electrical Problem?

Discussion in 'Technical Q&A' started by AndyB88, Feb 18, 2018.

  1. AndyB88

    AndyB88 Rookie

    Feb 18, 2018
    5
    Full Name:
    Andy Brothers
    Hi all - so I got in my F430 today after not driving it for a month (and quite chilly). It started fine, although I noticed that the gear indicator light and all gauges were not functioning. The car clicked into 1st gear no problem, but then would not shift into 2nd (and all gauges still not working). I drove around in 1st for 5 mins, and still could not change into 2nd. So I drove back home and parked - could go into reverse and neutral no problem. Clutch seems fine and no lag.......any ideas as to what might be case of this?
     
  2. greyboxer

    greyboxer F1 World Champ

    Dec 8, 2004
    10,772
    South East
    Full Name:
    Jimmie
    Welcome - there may be other ideas in the 360/430 section but had your car been on its charger for the month and did you definitely receive 'check ok' - it could be the battery was weak and/or old especially if not on charge
     
  3. AndyB88

    AndyB88 Rookie

    Feb 18, 2018
    5
    Full Name:
    Andy Brothers
    Thanks Greyboxer - it wasn't on charger and started up fine. I'm gonna try again later when I get back, but as it got started and I could drive off (albeit only in 1st gear), would a flat battery have that sort of result......if flat, would the car simply not start? To be honest, I know very little about the mechanics of the cars...so hoping for some ideas before having to take it to the shop :(
     
  4. greyboxer

    greyboxer F1 World Champ

    Dec 8, 2004
    10,772
    South East
    Full Name:
    Jimmie
    The various model sections are full of threads about screwy electrics due to weak batteries - if you can charge first to rule it out - a month is too long
     
  5. Alcav5

    Alcav5 Formula 3
    Silver Subscribed Rossa Subscribed

    Jul 28, 2012
    2,476
    Scarsdale, NY
    Full Name:
    Al
    Agreed sounds like battery. I don't let my car sit more than a week not on the charger. Even still in my experience I had a 2 yr old battery weaken and had to be changed. I was surprised especially since I had been used to having my other cars' batteries last a lot longer. Once in a while I'll start up the car and come across an abnormal indication. I shut the car down immediately wait a few sec and restart it. 9 time out 10 it's cleared.
     
  6. AndyB88

    AndyB88 Rookie

    Feb 18, 2018
    5
    Full Name:
    Andy Brothers
    OK thanks guys - I will try to change the battery first. Last night still had same problem, even after driving around the block a few times in 2nd gear.....:(
     
  7. MerlinTech

    MerlinTech Formula Junior
    Sponsor

    Mar 5, 2010
    519
    Georgia
    Full Name:
    Wade Williams
    So now you can get first and second gear?
    I would try disconnect/reconnect of the battery and try to start over and see if it is happy.
    If the battery is cranking the car without issue, I am not sure it is a battery problem.
     
  8. AndyB88

    AndyB88 Rookie

    Feb 18, 2018
    5
    Full Name:
    Andy Brothers
    Yes - ok I will try this today.....
     
  9. AndyB88

    AndyB88 Rookie

    Feb 18, 2018
    5
    Full Name:
    Andy Brothers
    So I changed the battery and this solved the problem. But odd, because the car could still start (so battery was not super flat), but could not change from 2nd to 3rd gear, and no instrument lights were on (even when driving).....once battery was changed, everything back to normal......
     
    Qavion likes this.

Share This Page