News

Glove box glitch

Discussion in '612/599' started by brogenville, Aug 14, 2019 at 6:18 PM.

  1. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Hello gents,
    I turned the ignition on the other day in my 612, and at the exact moment the key turned all the way to the start position, the glove box opened all by itself.
    “Hmmmm... weird” I though.

    Well, now the fecker won’t open at all on the button (pull cord still works fine).

    Checked the fuse, and it’s fine, so I’m a bit mystified.

    Anything similar happened to anyone else?
     
  2. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Ok, so looks like there’s no power getting to the glove box motor now. Motor works fine too if I supply it with a 12v pulse.

    Sooooo.... I’m thinking the issue is the relay. Ferrari, in their infinite wisdom, chose not to actually explain where it is in the handbook at least not in my version). They show where the other relays are, but number 00 for the glovebox motor is up to you to find.

    Anyone got any clues as to where it’s lurking?
     
  3. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
  4. Radu

    Radu Rookie

    Jun 3, 2018
    12
    Full Name:
    Radu Popescu
    I love the fact that you're keeping at it despite not getting any replies - you're doing everyone a service, thank you.
     
    Modena_2003 likes this.
  5. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Might as well! Even if it doesn't help me, it could be a useful reference to someone else one day. :)
     
    Modena_2003 and Radu like this.
  6. Rex71

    Rex71 Formula Junior
    Rossa Subscribed

    Mar 24, 2007
    263
    Jeddah,Saudi Arabia
    Full Name:
    Majd B.
    Try locking and unlocking the car 3 times and then check if this solves the glove box problem.

    The above is kind of a reset procedure that can solve some issues related to doors or trunk relays.
     
  7. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Good shout- worth giving that a shot.
     
  8. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Found the relay- it’s the one just tucked in next to the right hand engine ecu under the floor cover.

    Relay tested fine though, and if I hotwire the connections to the glovebox motor, it opens just as you would expect. Problem must be upstream then.

    So I decided to look at the glove box switch. I found the connections for the push to make switch, and I can see the resistance dropping to zero across them when the switch is depressed, so it seems to be working. One thing of note was that the switch illumination wasn’t working when the rest of the interior illumination was.

    Of the three wires going to the switch, the middle one is the earth and seems fine (no resistance when linked to a known good earth), but the other two both go from 0 to 12v when the lights are switched on. Seems odd that they would both do that?

    Will need to keep pondering; feel free to express any words of inspiration!

    Oh- and I tried the lock reset procedure- no joy there I’m afraid.
     
  9. Melvok

    Melvok F1 World Champ
    Rossa Subscribed Owner

    Jul 25, 2008
    12,600
    Amersfoort, Holland.
    Full Name:
    Mel
    Disconnect the battery for 2 minutes and connect again: the "hard reset"....

    Tell us ...
     
  10. brogenville

    brogenville Karting

    Apr 24, 2012
    130
    UK
    Full Name:
    Robin
    Tried the hard reset- no joy.

    There’s definitely something weird with the interior lighting- the cigarette lighter illumination isn’t coming on as it should either- but if I touch the cigarette lighter down the light comes on AND even more strangely, the glovebox opens.

    Starting to think this is an issue with the BCM. Only other thing I can think of is that the LED has gone in the glove box switch and that’s somehow causing this.
     
    350MH83 likes this.

Share This Page