News

radio problem

Discussion in 'Technical Q&A' started by tiger 6, Sep 26, 2004.

  1. tiger 6

    tiger 6 Karting

    Aug 7, 2004
    99
    virginia
    Full Name:
    Stephen C Darrah
    My son was driving my '01 550 a couple of days ago. When he turned on the radio, he heard 4 "beeps" and no sound from the speakers. I have never had any problems previously with the radio and am hoping someone can give me an idea as to what the problem is and how to fix it.
    Thanks.
     
  2. 911Fan

    911Fan Formula 3

    Apr 15, 2004
    1,291
    Southern California
    If it's the same Becker unit they use on other Ferraris, it might have lost its security code (was the car battery down/out?). You'll need to consult the radio manual for the re-programming instructions. And, hopefully, you still have the slip of paper with the security code somewhere in your files. If you didn't buy it new and the seller didn't give you the radio manual or the code, you'll probably have to get the dealer involved...
     
  3. teachdna

    teachdna Formula Junior

    Sep 1, 2001
    374
    Cincinnati
    Full Name:
    Jeffrey Robbins
    Probably the security code. But sometimes on these units there's a speaker wire around the kickplate in the door panel that goes bad. That has the consequence of shorting out the whole unit so you get no sound from any of the speakers. It's an easy fix: did you have any transient outages before this happened?

    If the dealers mis-diagnose the problem and tell you the radio is no good, don't believe them. PM me for more info if you need it and good luck.
     
  4. tiger 6

    tiger 6 Karting

    Aug 7, 2004
    99
    virginia
    Full Name:
    Stephen C Darrah
    Thanks for the response. The battery has not been disconnected and the unit is the Becker OEM radio/cd player which came with the car. The strange aspect of this is that all the radio/cd functions work as normal-just don't have any sound.
    I have thought about disconnecting the battery, re-entering the security code and seeing if this fixes the problem.
     
  5. rmfurzeland

    rmfurzeland Formula Junior

    Jan 7, 2005
    545
    Houston, TX
    Full Name:
    Ron Furzeland
    I have the same problem.
    Battery died, when replaced entered radio codes and tuner section works but no sound just like it was on mute.
    Did anyone solve this problem?
    Regards,
    Ron
     
  6. trickie

    trickie Rookie

    May 5, 2005
    25
    those beeps mean the radio thinks the faceplate is open

    try cleaning the contacts with a pencil eraser
     

Share This Page