News

Scuderia brake problems??

Discussion in 'Technical Q&A' started by lung7707, Mar 8, 2009.

  1. lung7707

    lung7707 F1 World Champ

    Jan 13, 2002
    15,965
    Honolulu, Hawaii
    Full Name:
    Rupert 9.0
    I took my car out to Malaysia Sepang F1 track last Friday. It was a 350km drive to get to the track.
    On the way up at high speed braking I found the car's CCM brakes to be very stiff/hard and less feel than perhaps my previous CS or 430.

    At the track I needed to muscle the brakes, literally stand on them before the ABS came on. It didn't feel rite... unlike other CCM brakes where if u slam on them it'll take u out thru the windshield. It just felt like it took a long time for the car to stop.

    Its got nothing to do with warming up coz it was still happening after a few laps.

    Anyone know if the Scud has a new brake system compared to the CS? The CS always stopped dead when you slammed on the brakes. Anyone know what could be happening?

    Feedback please

    Also posting on the 430 section...
     
  2. To remove this ad click here.

  3. F430GT

    F430GT Formula 3

    Sep 29, 2005
    1,300
    Marco Island, FL
    Actually, I think the Scuderia brakes are very sensitive, a slight brake application causes substantial deceleration.

    I would first flush the brake lines to isolate any presence of air in the system , while at it, flush with Castrol SRF. Sounds like a problem specific to your car.
     
  4. lung7707

    lung7707 F1 World Champ

    Jan 13, 2002
    15,965
    Honolulu, Hawaii
    Full Name:
    Rupert 9.0
    Thanks for your reply.
    Probably is a problem specific to my car... the mechanics have sanded down the pads too to eliminate the possibility that the pads were not bedded properly ...and also to remove any burnt and glazed areas on the pads. Have not tested the car past 200kmph yet so hard to tell if its worked.
     
  5. Sfumato

    Sfumato F1 Veteran
    Rossa Subscribed

    Nov 1, 2003
    9,722
    Llanfairpwllgwyngyll, Anglesey, Wales
    Full Name:
    Angus Podgorney
    Had to change fluid in my 599. Cooked it in a hot soak in traffic. Your master is up front, so less likely that issue, but would change fluid anyway. My pedal went really soft after a hard 12mi run following a hot soak on 98 degrees. Factory said it was driver error. No, driver error would have stuffed the car in the 120mph corner where the pedal went away. Brakes fine now with new fluid, many hi speed runs without problems.
     
  6. Andy hls

    Andy hls Formula Junior

    Dec 17, 2003
    653
    Kent UK
    Full Name:
    Andy
    I dont think the problem is only your car, i have driven 3 differant scuds and the brakes are terrible compared to the cs,i think its a programme issue,it doesnt feel right to me.
     
  7. To remove this ad click here.

Share This Page