News

Speedo jump at mobile traffic lights

Discussion in '308/328' started by JonWH, Apr 13, 2021.

  1. JonWH

    JonWH Rookie

    Aug 13, 2020
    15
    Full Name:
    Jonny
    A couple of times, my speedometer has jumped to 150mph when pootling through a set of temporary traffic lights at roadworks. Is this a known phenomenon? I guess it's interference from the traffic lights affecting the speedo sensor. (UK 1988 328GTS btw).
     
  2. To remove this ad click here.

  3. Lawrence Coppari

    Lawrence Coppari Formula 3

    Apr 29, 2002
    1,972
    Kingsport, TN
    Full Name:
    Lawrence A. Coppari
    I generally slow down for road construction.;)
     
    Saabguy and JuLiTrO like this.
  4. ferrariowner

    ferrariowner Formula Junior

    Feb 21, 2014
    804
    Mansfield, TX
    Full Name:
    Ron
    I have experienced the same issue in the past. I have not tried to correct it since it happens infrequently. I am certain the cause is a bad or loose ground or possibly bad solder joint on speedometer circuit board. I am interested to hear if others have experienced this issue and how they resolved it.
     
  5. maurice70

    maurice70 F1 Rookie

    Jan 25, 2004
    4,131
    Sydney
    Full Name:
    maurice T
    Funny you should mention it but on Sunday I went for a long drive, mainly freeway and then I got off and entered a small town where they were conducting roadworks and they had a mobile traffic light set up and then when I took off, I noticed my speedometer had stopped working.

    I stopped at my destination for a few hours then when I got back in, it started working again but only for about 10 minutes or so and then died..

    Tried again the next day and the same thing, would work for 10 odd minutes and then stop.

    A mechanic friend of mine also has a 328 so we were able to swap speedometers to see if it was the speedometer but it wasn’t so it must be the dreaded Speed sensor unit which has shot up in price over the years..
     
  6. barabba

    barabba Formula Junior

    Jun 7, 2007
    615
    Ticino / Zurich
    Haven’t experienced this on the 328 but seen it last week I hole driving another car (Alfa Romeo SZ).
     
  7. To remove this ad click here.

  8. maurice70

    maurice70 F1 Rookie

    Jan 25, 2004
    4,131
    Sydney
    Full Name:
    maurice T
    Could be the sending unit as well as I know the Alfa Romeo Spider Series 4 used the same sender so there’s a good chance the SZ does as well.
     

Share This Page