News

Spider roof latching

Discussion in '360/430' started by AndrewCrane, Jan 13, 2008.

  1. AndrewCrane

    AndrewCrane Karting

    Sep 25, 2007
    76
    Chobham, Surrey, UK
    Full Name:
    Andrew Crane
    Hi - my 430 has trouble latching the roof - so much so that the motor cut out, presumably as an overheat protection. Has anyone else had the problem, and was it a simple microswitch adjustment or something more likely to take the thing off the road for a while?

    Thanks,
    Andrew
     
  2. To remove this ad click here.

  3. sjolly

    sjolly Guest

    Apr 10, 2006
    86
    toronto
    battery might be low
     
  4. hydraaa

    hydraaa Rookie

    Sep 3, 2007
    39
    Same problem here...just got the car this fall and the roof latches about 50% of the time...am going to bring it into the
    dealership in the spring to have it checked out...but would love to know if this is a common problem on a 2007
    spider...with 900 miles on it...
     
  5. Steve711

    Steve711 Karting

    Oct 9, 2007
    105
    I have the problem on my 07 with 190 miles. I suspect the top just needs to stretch out a little. I haven't had a day in the hot sun yet. I give it a little help with my hand and it latches without a problem.
     
  6. lapeter

    lapeter Formula Junior

    Jun 13, 2002
    885
    SunValley ID&Kapalua
    Full Name:
    Al LaPeter
    With my '07 spider, the top is tight and I always raise or lower with the engine ON. Sometimes in closing I have to help it the last two inches. I think the top is just tight. With the engine off and a fully charged battery, it will not close very well.
    Al
     
  7. To remove this ad click here.

  8. scycle2020

    scycle2020 F1 Rookie

    Jan 26, 2004
    3,458
    potomac
    Interesting enough, with my 02 360 spider, and 3 other friends with 360 spiders, never had this problem....and the 430 top is the same as the 360 as far as i know....
     
  9. rslpartners

    rslpartners Karting
    BANNED

    Jun 22, 2006
    59
    S.F. Bay Area
    Got a 190 miles on mine.
    Picked it up on 12.21.07.
    Had to help it along a couple of times.
    I'm assuming it's just tight and need a little break-in....I hope.
     

Share This Page