News

TPMS troubleshoot

Discussion in '612/599' started by TrojanFan, Apr 3, 2020.

  1. TrojanFan

    TrojanFan F1 Rookie
    Silver Subscribed Owner

    Nov 17, 2008
    4,285
    So. CA & NV
    Full Name:
    Peter
    #1 TrojanFan, Apr 3, 2020
    Last edited: Apr 3, 2020
    My TPMS is working intermittingly. All of the tire sensors were replaced about 18 months ago and are all working. Scanning with a Leonardo clone shows them all reporting accurate pressure.

    Almost every time i start the car, i get a low pressure warning. I go through the reset and sometimes it clears and sometimes not. Then on occasion, iI get a tire puncture warning.

    Is there a weak link it the system that is a common problem other than the pressure sending units in the wheels? Does the receiver go out? Any inexpensive fix or replacement? Ricambi lists the ECU as unavailable. Any other non-Ferrari use the same part?
     
  2. To remove this ad click here.

  3. TrojanFan

    TrojanFan F1 Rookie
    Silver Subscribed Owner

    Nov 17, 2008
    4,285
    So. CA & NV
    Full Name:
    Peter
    The ecu is also used in the Maserati QP of the same era. Hoping its also used on something less exotic.
     
  4. brogenville

    brogenville Formula Junior
    Silver Subscribed

    Apr 24, 2012
    858
    UK
    Full Name:
    Robin
  5. TrojanFan

    TrojanFan F1 Rookie
    Silver Subscribed Owner

    Nov 17, 2008
    4,285
    So. CA & NV
    Full Name:
    Peter
    Of course I went on a 250 mile drive on Friday and everything worked perfectly.
     

Share This Page